Freeze Property (ActiveX)

Specifies the freeze status of a layer.

Supported platforms: Windows only

Signature

VBA:

object.Freeze
object

Type: Layer

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

Freezing layers makes them invisible and excludes them from regeneration and plotting. Thawing a layer enables these capabilities. AutoCAD surfaces and circles on a turned-off or frozen layer are invisible, but they still hide objects when you use the HIDE, SHADEMODE, or RENDER commands.

You cannot freeze the active layer, or make a frozen layer active.

This property differs from the LayerOn property because frozen layers are not generated during a regeneration.

Examples

VBA:

Sub Example_Freeze()
    ' This example creates a new layer called "Freeze".
    ' It then displays the status of the Freeze property
    ' for the new layer, toggles the status of the
    ' Freeze property, and again displays its status.
    ' After running this example, you can check the layer
    ' control on the Object Properties tool bar. It will
    ' show the new layer and the latest Freeze status.
    
    Dim layerObj As AcadLayer
    
    ' Create the new layer
    Set layerObj = ThisDrawing.Layers.Add("Freeze")
    
    ' Display the Freeze status of the new layer
    GoSub DISPLAYSTATUS
    
    ' Toggle the status of the Freeze property for the layer
    layerObj.Freeze = Not (layerObj.Freeze)
    
    ' Display the Freeze status of the new layer
    GoSub DISPLAYSTATUS
    Exit Sub
    
DISPLAYSTATUS:
    If layerObj.Freeze Then
        MsgBox "Layer " & layerObj.name & " is frozen.", , "Freeze Example"
    Else
        MsgBox "Layer " & layerObj.name & " is thawed.", , "Freeze Example"
    End If
    Return
        
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Freeze()
    ;; This example creates a new layer called "Freeze".
    ;; It then displays the status of the Freeze property
    ;; for the new layer, toggles the status of the
    ;; Freeze property, and again displays its status.
    ;; After running this example, you can check the layer
    ;; control on the Object Properties tool bar. It will
    ;; show the new layer and the latest Freeze status.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Create the new layer
    (setq layerObj (vla-Add (vla-get-Layers doc) "Freeze"))
    
    ;; Display the Freeze status of the new layer
    (if (= (vla-get-Freeze layerObj) :vlax-true)
        (alert (strcat "Layer " (vla-get-Name layerObj) " is frozen."))
        (alert (strcat "Layer " (vla-get-Name layerObj) " is thawed."))
    )
    
    ;; Toggle the status of the Freeze property for the layer
    (vla-put-Freeze layerObj (if (= (vla-get-Freeze layerObj) :vlax-true) :vlax-false :vlax-true))
    
    ;; Display the Freeze status of the new layer
    (if (= (vla-get-Freeze layerObj) :vlax-true)
        (alert (strcat "Layer " (vla-get-Name layerObj) " is frozen."))
        (alert (strcat "Layer " (vla-get-Name layerObj) " is thawed."))
    )
)