AddPoint Method (ActiveX)

Creates a Point object at a given location.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddPoint(Point)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

Point

Access: Input-only

Type: Variant (three-element array of doubles)

The coordinates of the point to be created.

Return Value (RetVal)

Type: Point

The newly created Point object.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddPoint()
    ' This example creates a point in model space.
    Dim pointObj As AcadPoint
    Dim location(0 To 2) As Double
    
    ' Define the location of the point
    location(0) = 5#: location(1) = 5#: location(2) = 0#
    
    ' Create the point
    Set pointObj = ThisDrawing.ModelSpace.AddPoint(location)
    ZoomAll
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddPoint()
    ;; This example creates a point in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the location of the point
    (setq location (vlax-3d-point 5 5 0))
    
    ;; Create the point
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq pointObj (vla-AddPoint modelSpace location))
    (vla-ZoomAll acadObj)
)