Material Property (ActiveX)

Specifies the name of the material.

Supported platforms: Windows only

Signature

VBA:

object.Material
object

Type: All drawing objects, AttributeReference, Group, Layer, SubDMeshFace, SubEntSolidFace

The objects this property applies to.

Property Value

Read-only: No

Type: String

The name of the material.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddMaterial()
    Dim oMaterial As AcadMaterial
    Dim oMaterials As AcadMaterials
    Set oMaterial = ThisDrawing.Materials.Add("TestMaterial")
    oMaterial.Description = "This material demonstrates how to add a material to a database."
    ThisDrawing.ActiveMaterial = oMaterial
    
    ' Display the name and description of the layer
    MsgBox oMaterial.Name & " has been added." & vbCrLf & _
            "Name: " & vbCrLf & oMaterial.Name & vbCrLf & vbCrLf & _
            "Description: " & vbCrLf & _
            oMaterial.Description

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Materials()
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq oMaterial (vla-Add (vla-get-Materials doc) "TestMaterial"))
    (vla-put-Description oMaterial "This material demonstrates how to add a material to a database.")
    (vla-put-ActiveMaterial doc oMaterial)
    ;; Display the status of the new layer
    (alert (strcat (vla-get-Name oMaterial) " has been added."
            "\nName: " (vla-get-Name oMaterial)
            "\nDescription: " (vla-get-Description oMaterial)))
)