Delta Property (ActiveX)

Gets the delta of a line.

Supported platforms: Windows only

Signature

VBA:

object.Delta
object

Type: Line

The object this property applies to.

Property Value

Read-only: Yes

Type: Variant (three-element array of doubles)

A three-element array representing the deltaX, deltaY, and deltaZ values for the line.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Delta()
    ' This example adds a line in model space and returns the delta of the new line

    Dim lineObj As AcadLine
    Dim lineDelta As Variant
    Dim startPoint(0 To 2) As Double, endPoint(0 To 2) As Double
    
    ' Define the start and end points for the line
    startPoint(0) = 1: startPoint(1) = 1: startPoint(2) = 0
    endPoint(0) = 5: endPoint(1) = 5: endPoint(2) = 0
    
    ' Create the line in model space
    Set lineObj = ThisDrawing.modelSpace.AddLine(startPoint, endPoint)

    ThisDrawing.Application.ZoomAll
    
    ' Display the delta of the new line
    lineDelta = lineObj.Delta
    MsgBox "The delta of the new Line is: " & vbCrLf & _
           "DeltaX: " & lineDelta(0) & vbCrLf & _
           "DeltaY: " & lineDelta(1) & vbCrLf & _
           "DeltaZ: " & lineDelta(2)
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Delta()
    ;; This example adds a line in model space and returns the delta of the new line
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Define the start and end points for the line
    (setq startPoint (vlax-3d-point 1 1 0)
          endPoint (vlax-3d-point 5 5 0))
    
    ;; Create the line in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq lineObj (vla-AddLine modelSpace startPoint endPoint))
    (vla-ZoomAll acadObj)
    
    ;; Display the delta of the new line
    (setq lineDelta (vlax-safearray->list (vlax-variant-value (vla-get-Delta lineObj))))
    (alert (strcat "The delta of the new Line is: "
                   "\nDeltaX: " (rtos (nth 0 lineDelta) 2)
                   "\nDeltaY: " (rtos (nth 1 lineDelta) 2)
                   "\nDeltaZ: " (rtos (nth 2 lineDelta) 2)
	   )
    )
)