DimensionLineExtend Property (ActiveX)

Specifies the distance the dimension line extends beyond the extension line when oblique strokes are drawn instead of arrowheads.

Supported platforms: Windows only

Signature

VBA:

object.DimensionLineExtend
object

Type: DimAligned, DimArcLength, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Double

A positive real number specifying the distance to extend the dimension line beyond the extension line.

Remarks

The initial value for this property is 0.0000.

Note: This property overrides the value of the DIMDLE system variable for the given dimension.

Examples

VBA:

Sub Example_DimensionLineExtend()
   ' This example creates an aligned dimension in model space and
   ' uses DimensionLineExtend to specify the distance the dimension
   ' line extends beyond the extension line when oblique strokes are
   ' drawn instead of arrowheads

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 10.123: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    dimObj.Arrowhead1Type = acArrowOblique
    dimObj.Arrowhead2Type = acArrowOblique
    
    ThisDrawing.Application.ZoomAll
    
    MsgBox "A new Dimension has been created.  Press any key to extend the dimension lines."
    
    ' Round the distance of the alternate dimension to 0.50 of a unit
    dimObj.DimensionLineExtend = 2
    ThisDrawing.Regen acAllViewports
    
    MsgBox "The dimension lines have been extended to: " & dimObj.DimensionLineExtend
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DimensionLineExtend()
    ;; This example creates an aligned dimension in model space and
    ;; uses DimensionLineExtend to specify the distance the dimension
    ;; line extends beyond the extension line when oblique strokes are
    ;; drawn instead of arrowheads
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 10.123 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-put-Arrowhead1Type dimObj acArrowOblique)
    (vla-put-Arrowhead2Type dimObj acArrowOblique)
    
    (vla-ZoomAll acadObj)
    
    (alert "A new Dimension has been created.")
    
    ;; Round the distance of the alternate dimension to 0.50 of a unit
    (vla-put-DimensionLineExtend dimObj 2)
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "The dimension lines have been extended to: " (rtos (vla-get-DimensionLineExtend dimObj) 2)))
)