TextStyles Property (ActiveX)

Gets the TextStyles collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.TextStyles
object

Type: Database, Document

The objects this property applies to.

Property Value

Read-only: Yes

Type: TextStyles

The TextStyles collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_TextStyles()
    ' This example finds the current Textstyles collection and
    ' adds a new Text style to that collection.
    
    Dim TextColl As AcadTextStyles
    Set TextColl = ThisDrawing.TextStyles
    
    ' Create a Text style named "TEST" in the current drawing
    Dim textStyle As AcadTextStyle
    Set textStyle = TextColl.Add("TEST")
    MsgBox "A new Text style called " & textStyle.name & " has been added to the Textstyles collection.", vbInformation, "Textstyles Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextStyles()
    ;; This example finds the current Textstyles collection and
    ;; adds a new Text style to that collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq TextColl (vla-get-TextStyles doc))
    
    ;; Create a Text style named "TEST" in the current drawing
    (setq textStyle (vla-Add TextColl "TEST"))
    (alert (strcat "A new Text style called " (vla-get-Name textStyle) " has been added to the Textstyles collection."))
)