ShortcutMenu Property (ActiveX)

Determines if the specified popup menu is the shortcut menu.

Supported platforms: Windows only

Signature

VBA:

object.ShortcutMenu
object

Type: PopupMenu

The object this property applies to.

Property Value

Read-only: Yes

Type: Boolean

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ShortcutMenu()
    ' This example iterates through the menus collection and
    ' determines if each menu is the shortcut menu.
    
    ' Note that depending on how many menus are currently loaded, the
    ' menuStatus string may not be displayed in full.
    
    Dim currMenu As AcadPopupMenu
    Dim menuStatus As String
    
    menuStatus = ""
    For Each currMenu In ThisDrawing.Application.MenuGroups.Item(0).Menus
    If currMenu.shortcutMenu Then
        menuStatus = menuStatus & currMenu.name & " is the shortcut menu." & vbCrLf
    Else
        menuStatus = menuStatus & currMenu.name & " is not the shortcut menu." & vbCrLf
    End If
    Next currMenu
    MsgBox menuStatus
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ShortcutMenu()
    ;; This example iterates through the menus collection and
    ;; determines if each menu is the shortcut menu.
    (setq acadObj (vlax-get-acad-object))
  
    ;; Note that depending on how many menus are currently loaded, the
    ;; menuStatus string may not be displayed in full.
    
    (setq menuStatus "")
    (vlax-for currMenu (vla-get-Menus (vla-Item (vla-get-MenuGroups acadObj) 0))
        (if (= (vla-get-ShortcutMenu currMenu) :vlax-true)
            (setq menuStatus (strcat menuStatus (vla-get-Name currMenu) " is a shortcut menu.\n"))
            (setq menuStatus (strcat menuStatus (vla-get-Name currMenu) " is not a shortcut menu.\n"))
        )
    )

    (alert menuStatus)
)