Clipped Property (ActiveX)

Determines if the viewport has been clipped.

Supported platforms: Windows only

Signature

VBA:

object.Clipped
object

Type: PViewport

The object this property applies to.

Property Value

Read-only: Yes

Type: Boolean

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Clipped()
    ' This example scans the current drawing paper space Viewports
    ' and displays whether or not any of them are clipped.
    
    Dim pviewportObj As Object
    Dim msg As String, ClippedState As String
    
    ' Make sure this drawing contains paper space viewports before continuing
    If ThisDrawing.PaperSpace.Count = 0 Then
        MsgBox "There are no paper space viewports in the current drawing."
        Exit Sub
    End If
    
    ' Go through each PViewport object in the drawing paper space
    ' and determine whether the paper space viewport is clipped or not

    For Each pviewportObj In ThisDrawing.PaperSpace
        ' Determine if this is a paper space viewport
        If pviewportObj.ObjectName = "AcDbViewport" Then
            ' Determine if this paper space viewport is clipped
            ClippedState = IIf(pviewportObj.Clipped, " is clipped", " is not clipped")
            msg = msg & "PViewport ID " & pviewportObj.ObjectID & ClippedState & vbCrLf
        End If
    Next

    ' Display clipped state of paper space Viewports
    MsgBox msg
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Clipped()
    ;; This example scans the current drawing paper space Viewports
    ;; and displays whether or not any of them are clipped.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Make sure this drawing contains paper space viewports before continuing
    (if (= (vla-get-Count (vla-get-PaperSpace doc)) 0)
        (alert "There are no paper space viewports in the current drawing.")
        (progn
	    ;; Go through each PViewport object in the drawing paper space
	    ;; and determine whether the paper space viewport is clipped or not
    	    (setq msg "")
    
	    (vlax-for pviewportObj (vla-get-PaperSpace doc)
	        ;; Determine if this is a paper space viewport
	        (if (= (vla-get-ObjectName pviewportObj) "AcDbViewport")
	            (progn
	                ;; Determine if this paper space viewport is clipped
	                (setq ClippedState (if (= (vla-get-Clipped pviewportObj) :vlax-true) " is clipped" " is not clipped"))
	                (setq msg (strcat msg "PViewport ID " (itoa (vla-get-ObjectID pviewportObj)) ClippedState "\n"))
		    )
	        )
	    )

	    ;; Display clipped state of paper space Viewports
	    (alert msg)
	)
    )
)