Triggered just before an AutoCAD session ends or a document closes.
Supported platforms: Windows only
VBA:
object.BeginQuit(Cancel)
Type: Application
An object expression that evaluates to a valid container object. In this case, the only valid container is the application.
Type: Boolean; output from the handler
The BeginQuit event marks the end of the AutoCAD session.
VBA:
Public WithEvents ACADApp As AcadApplication ' Use with Application Event Examples
Sub Example_AcadApplication_Events()
' This example intializes the public variable (ACADApp) which will be used
' to intercept AcadApplication Events
'
' The VBA WithEvents statement makes it possible to intercept an generic object
' with the events associated with that object.
'
' Before you will be able to trigger any of the AcadApplication events,
' you will first need to run this procedure.
' We could get the application from the ThisDocument object, but that would
' require having a drawing open, so we grab it from the system.
Set ACADApp = GetObject(, "AutoCAD.Application.24")
End Sub
Private Sub ACADApp_BeginQuit(Cancel As Boolean)
' This example intercepts an Application BeginQuit event.
'
' This event is triggered when AutoCAD receives a request to shut down.
'
' To trigger this example event:
' 1) Make sure to run the example that initializes
' the public variable (named ACADApp) linked to this event.
'
' 2) Close the AutoCAD application
' Use the "Cancel" variable to stop the shut down of the application
If MsgBox("AutoCAD is about to shut down. Do you want to continue with the shutdown?", _
vbYesNoCancel + vbQuestion) <> vbYes Then
Cancel = True
End If
End Sub
Visual LISP:
Not available