Specifies the name of the popup menu without the underscore mnemonic.
Supported platforms: Windows only
Read-only: Yes
Type: String
The popup menu name without the underscore mnemonic.
No additional remarks.
VBA:
Sub Example_NameNoMnemonic() ' This example iterates through the menus collection and ' displays the Name and NameNoMnemonic property for each menu. ' Note that depending on how many menus are currently loaded, the ' menuStatus string may not be displayed in full. Dim currMenu As AcadPopupMenu Dim menuStatus As String menuStatus = "" For Each currMenu In ThisDrawing.Application.MenuGroups.Item(0).Menus menuStatus = menuStatus & currMenu.name & " -- " & currMenu.NameNoMnemonic & vbCrLf Next currMenu MsgBox menuStatus End Sub
Visual LISP:
(vl-load-com) (defun c:Example_NameNoMnemonic() ;; This example iterates through the menus collection and ;; displays the Name and NameNoMnemonic property for each menu. (setq acadObj (vlax-get-acad-object)) ;; Note that depending on how many menus are currently loaded, the ;; menuStatus string may not be displayed in full. (setq menuStatus "") (vlax-for currMenu (vla-get-Menus (vla-Item (vla-get-MenuGroups acadObj) 0)) (setq menuStatus (strcat menuStatus (vla-get-Name currMenu) " -- " (vla-get-NameNoMnemonic currMenu) "\n")) ) (alert menuStatus) )