Specifies the attribute text generation flag.
Supported platforms: Windows only
VBA:
object.TextGenerationFlag
Type: Attribute, AttributeReference, Text, TextStyle
The objects this property applies to.
Read-only: No
Type: acTextGenerationFlag enum
To specify both flags, add them together.
VBA:
Sub Example_TextGenerationFlag() ' This example creates a text object in model space. ' It then changes the TextGenerationFlag of the text object. Dim textObj As AcadText Dim textString As String Dim insertionPoint(0 To 2) As Double Dim height As Double ' Define the text object textString = "Hello, World." insertionPoint(0) = 3: insertionPoint(1) = 3: insertionPoint(2) = 0 height = 0.5 ' Create the text object in model space Set textObj = ThisDrawing.ModelSpace.AddText(textString, insertionPoint, height) ZoomAll MsgBox "The TextGenerationFlag has not been set.", vbInformation, "TextGenerationFlag Example" ' Change the value of the TextGenerationFlag textObj.TextGenerationFlag = acTextFlagBackward ZoomAll MsgBox "The TextGenerationFlag is set to acTextFlagBackward.", vbInformation, "TextGenerationFlag Example" textObj.TextGenerationFlag = acTextFlagUpsideDown ZoomAll MsgBox "The TextGenerationFlag is set to acTextFlagUpsideDown.", vbInformation, "TextGenerationFlag Example" textObj.TextGenerationFlag = acTextFlagBackward + acTextFlagUpsideDown ZoomAll MsgBox "The TextGenerationFlag is set to acTextFlagBackward + acTextFlagUpsideDown.", vbInformation, "TextGenerationFlag Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_TextGenerationFlag() ;; This example creates a text object in model space. ;; It then changes the TextGenerationFlag of the text object. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the text object (setq insertionPoint (vlax-3d-point 3 3 0) textString "Hello, World." height 0.5) ;; Create the text object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq textObj (vla-AddText modelSpace textString insertionPoint height)) (vla-ZoomAll acadObj) (alert "The TextGenerationFlag has not been set.") ;; Change the value of the TextGenerationFlag (vla-put-TextGenerationFlag textObj acTextFlagBackward) (vla-ZoomAll acadObj) (alert "The TextGenerationFlag is set to acTextFlagBackward.") (vla-put-TextGenerationFlag textObj acTextFlagUpsideDown) (vla-ZoomAll acadObj) (alert "The TextGenerationFlag is set to acTextFlagUpsideDown.") (vla-put-TextGenerationFlag textObj (+ acTextFlagBackward acTextFlagUpsideDown)) (vla-ZoomAll acadObj) (alert "The TextGenerationFlag is set to acTextFlagBackward + acTextFlagUpsideDown.") )