Groups Property (ActiveX)

Gets the Groups collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.Groups
object

Type: Database, Document

The object this property applies to.

Property Value

Read-only: Yes

Type: Groups

The Groups collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Groups()
    ' This example finds the current Groups collection and
    ' adds a new group to that collection.
    
    Dim groupColl As AcadGroups
    Set groupColl = ThisDrawing.Groups
    
    ' Create a dimension style named "TEST" in current drawing
    Dim testGroup As AcadGroup
    Set testGroup = groupColl.Add("TEST")
    MsgBox "A new group called " & testGroup.name & " has been added to the Groups collection.", vbInformation, "Groups Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Groups()
    ;; This example finds the current Groups collection and
    ;; adds a new group to that collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq groupColl (vla-get-Groups doc))
    
    ;; Create a dimension style named "TEST" in current drawing
    (setq testGroup (vla-Add groupColl "TEST"))
    (alert (strcat "A new group called " (vla-get-Name testGroup) " has been added to the Groups collection."))
)