Toggles the display of frames around the multileader text content with a text box or for text objects instead of displaying the text itself.
Supported platforms: Windows only
VBA:
object.TextFrameDisplay
Type: DatabasePreferences, GeoPositionMarker, MLeader
The objects this property applies to.
Read-only: No
Type: Boolean
Read-only: No
Type: Boolean
The initial value for this property is False.
DatabasePreferences: After you enable or disable this option, you must use the Regen method to update the display.
VBA:
Sub Example_TextFrameDisplay() ' This example returns the current setting of ' TextFrameDisplay. It then changes the value, and finally ' it resets the value back to the original setting. Dim currTextFrameDisplay As Boolean ' Retrieve the current TextFrameDisplay value currTextFrameDisplay = ThisDrawing.Preferences.TextFrameDisplay MsgBox "The current value for TextFrameDisplay is " & Preferences.TextFrameDisplay, vbInformation, "TextFrameDisplay Example" ' Change the value for TextFrameDisplay ThisDrawing.Preferences.TextFrameDisplay = Not (currTextFrameDisplay) MsgBox "The new value for TextFrameDisplay is " & Preferences.TextFrameDisplay, vbInformation, "TextFrameDisplay Example" ' Reset TextFrameDisplay to its original value ThisDrawing.Preferences.TextFrameDisplay = currTextFrameDisplay MsgBox "The TextFrameDisplay value is reset to " & Preferences.TextFrameDisplay, vbInformation, "TextFrameDisplay Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_TextFrameDisplay() ;; This example returns the current setting of ;; TextFrameDisplay. It then changes the value, and finally ;; it resets the value back to the original setting. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) (setq preferences (vla-get-Preferences doc)) ;; Retrieve the current TextFrameDisplay value (setq currTextFrameDisplay (vla-get-TextFrameDisplay preferences)) (alert (strcat "The current value for TextFrameDisplay is " (if (= currTextFrameDisplay :vlax-true) "True" "False"))) ;; Change the value for TextFrameDisplay (vla-put-TextFrameDisplay preferences (if (= currTextFrameDisplay :vlax-true) :vlax-false :vlax-true)) (alert (strcat "The new value for TextFrameDisplay is " (if (= (vla-get-TextFrameDisplay preferences) :vlax-true) "True" "False"))) ;; Reset TextFrameDisplay to its original value (vla-put-TextFrameDisplay preferences currTextFrameDisplay) (alert (strcat "The TextFrameDisplay value is reset to " (if (= (vla-get-TextFrameDisplay preferences) :vlax-true) "True" "False"))) )