Length Property (ActiveX)

Gets the length of an object.

Supported platforms: Windows only

Signature

VBA:

object.Length
object

Type: 3DPolyline, Line, LWPolyline, PointCloud, Polyline, SweptSurface

The objects this property applies to.

Property Value

Read-only: Yes

Type: Double

The length of the line.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Length()
   ' This example adds a line in model space and returns the length of the new line

    Dim lineObj As AcadLine
    Dim startPoint(0 To 2) As Double, endPoint(0 To 2)  As Double
    
    ' Define the start and end points for the line
    startPoint(0) = 1: startPoint(1) = 1: startPoint(2) = 0
    endPoint(0) = 5: endPoint(1) = 5: endPoint(2) = 0

    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)

    ThisDrawing.Application.ZoomAll
    
    MsgBox "The length of the new Line is: " & lineObj.length
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Length()
    ;; This example adds a line in model space and returns the length of the new line
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the start and end points for the line
    (setq startPoint (vlax-3d-point 1 1 0)
          endPoint (vlax-3d-point 5 5 0))

    ;; Create the line in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq lineObj (vla-AddLine modelSpace startPoint endPoint))

    (vla-ZoomAll acadObj)
    
    (alert (strcat "The length of the new Line is: " (rtos (vla-get-Length lineObj) 2)))
)