Description Property (ActiveX)

Specifies the description of an object.

Supported platforms: Windows only

Signature

VBA:

object.Description
object

Type: DynamicBlockReferenceProperty, Layer, Linetype, Material, MLeaderStyle, TableStyle

The objects this property applies to.

Property Value

Read-only: No; except for DynamicBlockReferenceProperty objects

Type: String

The description assigned to the object.

Remarks

The description for a dynamic block reference property is set by the block author and cannot be edited.

A linetype description can have up to 47 characters. The description can be a comment or a series of underscores, dots, dashes, and spaces to show a simple representation of the linetype pattern.

Examples

VBA:

Sub Example_Description()
    ' This example returns the description of the active linetype.
    ' It then changes the description of the active linetype.
    
    Dim currDescription As String
    
    ' This example modifies the description of a linetype
    currDescription = ThisDrawing.ActiveLinetype.Description
    MsgBox "The description of the active LineType is: " & currDescription, vbInformation, "Description Example"

    ' Change the description of the active linetype
    ThisDrawing.ActiveLinetype.Description = "My favorite LineType"
    MsgBox "The new description of the active LineType is: " & ThisDrawing.ActiveLinetype.Description, vbInformation, "Description Example"
    
    ' Reset the description of the active linetype
    ThisDrawing.ActiveLinetype.Description = currDescription
    MsgBox "The description of the active LineType is reset to: " & ThisDrawing.ActiveLinetype.Description, vbInformation, "Description Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Description()
    ;; This example returns the description of the active linetype.
    ;; It then changes the description of the active linetype.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; This example modifies the description of a linetype
    (setq currDescription (vla-get-Description (vla-get-ActiveLinetype doc)))
    (alert (strcat "The description of the active Linetype is: " currDescription))

    ;; Change the description of the active linetype
    (vla-put-Description (vla-get-ActiveLinetype doc) "My favorite LineType")
    (alert (strcat "The new description of the active Linetype is: " (vla-get-Description (vla-get-ActiveLinetype doc))))
    
    ;; Reset the description of the active linetype
    (vla-put-Description (vla-get-ActiveLinetype doc) currDescription)
    (alert (strcat "The description of the active Linetype is reset to: " currDescription))
)