GenerateSectionGeometry Method (ActiveX)

Generates 2D or 3D section geometry.

Supported platforms: Windows only

Signature

VBA:

object.GenerateSectionGeometry pEntity, pIntersectionBoundaryObjs, pIntersectionFillObjs, pBackgroudnObjs, pForegroudObjs, pCurveTangencyObjs
object

Type: Section

The object this method applies to.

pEntity

Access: Input-only

Type: IAcadEntity

The sectionable entity.

pIntersectionBoundaryObjs

Access: Output-only

Type: Variant

The intersection boundary objects.

pIntersectionFillObjs

Access: Output-only

Type: Variant

The objects representing intersection fill annotation geometry.

pBackgroundObjs

Access: Output-only

Type: Variant

The background geometry objects.

pForegroundObjs

Access: Output-only

Type: Variant

The foreground geometry objects.

pCurveTangencyObjs

Access: Output-only

Type: Variant

The curve tangency geometry objects.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Not available

Visual LISP:

Not available