Dictionary Object (ActiveX)

A container object for storing and retrieving objects.

Supported Platforms: Windows only

Class Information

Class Name

AcadDictionary

Object Inheritance
Object
   AcadObject
      AcadDictionary
Create Using

VBA

Dictionaries.Add
Access Via

VBA

Dictionaries.Item

Members

These members are part of this object:

Remarks

Dictionaries provide a mechanism for storing and retrieving objects with associated string keywords.

The objects in a dictionary may be referenced by their keywords. A dictionary can contain any type of object, including other dictionaries. A dictionary does not perform type checking of entries.

You can create new dictionaries, add entries to an existing dictionary, and get the keyword for a given object or the object for a given keyword. You can change the object that is associated with a given keyword, or rename the keyword for a given object.

This dictionary is similar to a collection in AutoCAD, and is used for custom object implementation. This object does not represent the spell checking dictionary. The spell checking dictionary is specified in the Preferences object.

To add a dictionary to the application, use the Add method.