Used Property (ActiveX)

Specifies whether a layer is in use.

Supported platforms: Windows only

Signature

VBA:

object.Used
object

Type: Layer

The object this property applies to.

Property Value

Read-only: Yes

Type: Boolean

Remarks

This property specifies whether a layer is in use when the GenerateUsageData method is called.

Examples

VBA:

Sub Example_Used()
    ' This example provides usage information for the layers
    ' in a drawing
    Dim MyLayers As AcadLayers
    Set MyLayers = ThisDrawing.Layers
    MyLayers.GenerateUsageData
    
    Dim MyLayerObj As AcadLayer
    For Each MyLayerObj In ThisDrawing.Layers
        MyLayerObj.Description = "Test"
        MsgBox (MyLayerObj.Used)
    Next MyLayerObj
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Used()
    ;; This example provides usage information for the layers
    ;; in a drawing
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq MyLayers (vla-get-Layers doc))
    (vla-GenerateUsageData MyLayers)

    (vlax-for MyLayerObj (vla-get-Layers doc)
        (alert (strcat "Layer " (vla-get-Name MyLayerObj) (if (= (vla-get-Used MyLayerObj) :vlax-true) " is used." " is not used.")))
    )
)