PlotConfigurations Property (ActiveX)

Gets the PlotConfigurations collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.PlotConfigurations
object

Type: Database, Document

The object this property applies to.

Property Value

Read-only: Yes

Type: PlotConfigurations

The PlotConfigurations collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_PlotConfigurations()
    ' This example will access the PlotConfigurations collection for the current drawing,
    ' add a plot configuration, and list basic information about the
    ' plot configurations in the drawing.

    Dim PlotConfigurations As AcadPlotConfigurations
    Dim PlotConfiguration As AcadPlotConfiguration
    Dim msg As String
    
    ' Get PlotConfigurations collection from document object
    Set PlotConfigurations = ThisDrawing.PlotConfigurations
    
    ' If there aren't any plot configurations, then add one
    If PlotConfigurations.count = 0 Then
        '*** Customize the new configuration to your satisfaction ***
        PlotConfigurations.Add "NEW_CONFIGURATION"
    End If
    
    msg = vbCrLf     ' Start with a space
    
    ' Get the names of the plot configurations in this drawing
    For Each PlotConfiguration In PlotConfigurations
        msg = msg & PlotConfiguration.name & vbCrLf
    Next
    
    ' Display a list of available plot configurations
    MsgBox "There are " & PlotConfigurations.count & " plot configuration(s) in " & _
           ThisDrawing.WindowTitle & ":" & msg
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PlotConfigurations()
    ;; This example will access the PlotConfigurations collection for the current drawing,
    ;; add a plot configuration, and list basic information about the
    ;; plot configurations in the drawing.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Get PlotConfigurations collection from document object
    (setq PlotConfigurations (vla-get-PlotConfigurations doc))
    
    ;; If there aren't any plot configurations, then add one
    (if (= (vla-get-Count PlotConfigurations) 0)
        ;; *** Customize the new configuration to your satisfaction ***
        (vla-Add PlotConfigurations "NEW_CONFIGURATION")
    )
    
    (setq msg "")
    
    ;; Get the names of the plot configurations in this drawing
    (vlax-for PlotConfiguration PlotConfigurations
        (setq msg (strcat msg (vla-get-Name PlotConfiguration) "\n"))
    )
    
    ;; Display a list of available plot configurations
    (alert (strcat "There are " (itoa (vla-get-Count PlotConfigurations)) " plot configuration(s) in "
                   (vla-get-WindowTitle doc) ": \n" msg))
)