ObjectIDToObject Method (ActiveX)

Gets the object that corresponds to the given object ID.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.ObjectIDToObject(ID)
object

Type: Database, Document

The objects this method applies to.

ID

Access: Input-only

Type: Long_PTR

The object ID of the object to return.

Return Value (RetVal)

Type: Object

The object that corresponds to the given object ID.

Remarks

This method can return only objects that are in the current document.

Examples

VBA:

Sub Example_ObjectIDToObject()
    ' This example creates a spline in model space, and returns the
    ' handle for the spline. Then the spline is returned from the handle and colored.
    
    ' Create the spline
    Dim splineObj As AcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double
    
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    
    ZoomAll
    
    Dim objectID As Long
    objectID = splineObj.ObjectID
    MsgBox "The objectID of the Spline is: " & objectID, , "ObjectIDToObject Example"
        
    ' Find an object from a given objectID
    Dim tempObj As AcadObject
    Set tempObj = ThisDrawing.ObjectIdToObject(objectID)

    ' Now use the newly initialized object variable to color the object
    Dim color As AcadAcCmColor
    Set color = AcadApplication.GetInterfaceObject("AutoCAD.AcCmColor." & Left(AcadApplication.Version, 2))
    color.SetRGB 80, 100, 244
    
    tempObj.TrueColor = color
    
    ThisDrawing.Regen True
    MsgBox "The Spline is now blue.", , "ObjectIDToObject Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ObjectIDToObject()
    ;; This example creates a spline in model space, and returns the
    ;; handle for the spline. Then the spline is returned from the handle and colored.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Create the spline
    (setq startTan (vlax-3d-point 0.5 0.5 0)
          endTan (vlax-3d-point 0.5 0.5 0)
          fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8)))
    (vlax-safearray-fill fitPoints '(1 1 0
                                     5 5 0
                                     10 0 0
                                    )
    )

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan))
    (vla-ZoomAll acadObj)
    
    ;; Find the objectID of the spline
    (setq objectID (vla-get-objectID splineObj))
    (alert (strcat "The objectID of the Spline is: " (itoa objectID)))
        
    ;; Find an object from a given objectID
    (setq tempObj (vla-ObjectIDToObject doc objectID))

    ;; Now use the newly initialized object variable to color the object 
    (setq color (vlax-create-object (strcat "AutoCAD.AcCmColor." (substr (getvar "ACADVER") 1 2))))
    (vla-SetRGB color 80 100 244)
  
    (vla-put-TrueColor tempObj color)
    
    (vla-Regen doc :vlax-true)
    (alert "The Spline is now blue.")
    (vlax-release-object color)
)