Views Property (ActiveX)

Gets the Views collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.Views
object

Type: Database, Document

The object this property applies to.

Property Value

Read-only: Yes

Type: Views

The Views collection for the document.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Views()
    ' This example finds the current views collection and
    ' adds a new view to that collection.
    
    Dim viewColl As AcadViews
    Set viewColl = ThisDrawing.Views
    
    ' Create a view named "TEST" in the current drawing
    Dim viewObj As AcadView
    Set viewObj = viewColl.Add("TEST")
    MsgBox "A new view called " & viewObj.name & " has been added to the views collection.", vbInformation, "Views Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Views()
    ;; This example finds the current views collection and
    ;; adds a new view to that collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq viewColl (vla-get-Views doc))
    
    ;; Create a view named "TEST" in the current drawing
    (setq viewObj (vla-Add viewColl "TEST"))
    (alert (strcat "A new view called " (vla-get-Name viewObj) " has been added to the views collection."))
)