Custom property bag component, which stores custom properties. Every component that derives from IAcSmComponent has a GetCustomPropertyBag method. This method returns the property bag of the component.
AcSmCustomPropertyBag.GetDatabase Method (SSO)
Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmCustomPropertyBag.GetDirectlyOwnedObjects Method (SSO)
Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmCustomPropertyBag.GetObjectId Method (SSO)
Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmCustomPropertyBag.GetProperty Method (SSO)
Retrieves the IAcSmCustomPropertyValue specified with the Name parameter. If the method succeeds, the return value is S_OK. If the custom property value cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmCustomPropertyBag.InitNew Method (SSO)
Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.