AcSmAcDbLayoutReference.GetDatabase Method (SSO)
Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmAcDbLayoutReference.GetDirectlyOwnedObjects Method (SSO)
Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmAcDbLayoutReference.GetObjectId Method (SSO)
Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmAcDbLayoutReference.InitNew Method (SSO)
Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.