AcSmSheetSetMgr (SSO)
Sheet Set Manager object.
Topics in this section
AcSmSheetSetMgr.Close Method (SSO)
Closes a database.
AcSmSheetSetMgr.CloseAll Method (SSO)
Closes all open databases.
AcSmSheetSetMgr.CreateDatabase Method (SSO)
Creates a new database (DST file) and returns the
IAcSmDatabase
component for the database.
AcSmSheetSetMgr.FindOpenDatabase Method (SSO)
Checks the open databases for a specific database.
AcSmSheetSetMgr.GetDatabaseEnumerator Method (SSO)
Returns an enumerator of the currently open
IAcSmDatabase
components handled by the manager.
AcSmSheetSetMgr.GetParentSheetSet Method (SSO)
Attempts to find a sheet set that references a file name and layout. Any hints saved in the drawing are used.
AcSmSheetSetMgr.OpenDatabase Method (SSO)
Opens an existing database and returns the new
IAcSmDatabase
component for it.
AcSmSheetSetMgr.Register Method (SSO)
Registers a handler for callback notification. Returns a unique cookie for the handler.
AcSmSheetSetMgr.Unregister Method (SSO)
Unregisters a callback notification handler that was previously registered.
Related Concepts
Overview of Sheet Set Manager Objects (SSO)
Related Reference
Create or Open a Sheet Set Database (SSO)
AcSmSheetSetMgr.Close Method (SSO)
AcSmSheetSetMgr.CloseAll Method (SSO)
AcSmSheetSetMgr.CreateDatabase Method (SSO)
AcSmSheetSetMgr.FindOpenDatabase Method (SSO)
AcSmSheetSetMgr.GetDatabaseEnumerator Method (SSO)
AcSmSheetSetMgr.GetParentSheetSet Method (SSO)
AcSmSheetSetMgr.OpenDatabase Method (SSO)
AcSmSheetSetMgr.Register Method (SSO)
AcSmSheetSetMgr.Unregister Method (SSO)