AcSmSheetView.GetDatabase Method (SSO)
Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmSheetView.GetDirectlyOwnedObjects Method (SSO)
Returns an array of the directly owned objects. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmSheetView.GetIsDirty Method (SSO)
If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.
AcSmSheetView.GetNamedView Method (SSO)
Returns an IAcSmNamedAcDbObjectReference that points to the named AcDbView object on the sheet referenced by the sheet view component.
AcSmSheetView.GetObjectId Method (SSO)
Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmSheetView.InitNew Method (SSO)
Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.
AcSmSheetView.SetNamedView Method (SSO)
Sets the AcSmAcDbViewReference that points to the named AcDbView object on the sheet referenced by this sheet view component.
AcSmSheetView.SetOwner Method (SSO)
Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.