AcSmSheetSet.GetDatabase Method (SSO)
Retrieves the parent IAcSmDatabase object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmSheetSet.GetDefAltPageSetup Method (SSO)
Retrieves the IAcSmNamedAcDbObjectReference component that references the default page setup within the template containing alternative page setups.
AcSmSheetSet.GetDirectlyOwnedObjects Method (SSO)
Returns an array of the directly owned objects. If the method succeeds, the return value is S_OKS_OK. If the parent database cannot be found, S_FALSES_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmSheetSet.GetIsDirty Method (SSO)
If VARIANT_TRUE is returned, then the persistable component was modified and is committed when the owner AcSmDatabase is unlocked.
AcSmSheetSet.GetObjectId Method (SSO)
Retrieves the IAcSmObjectId of the object. If the method succeeds, the return value is S_OK. If the parent database cannot be found, S_FALSE is returned and the provided pointer is populated with null. All other return values indicate an error condition.
AcSmSheetSet.ImportSheet Method (SSO)
Constructs a new sheet component that references the existing layout pointed to by the provided AcSmAcDbLayoutReference.
AcSmSheetSet.InitNew Method (SSO)
Initialization of a newly created persistable object. This method and the Load method are the only two ways to initialize a persistable component.
AcSmSheetSet.SetDefAltPageSetup Method (SSO)
Sets the IAcSmNamedAcDbObjectReference component that references the default page setup within the template containing the alternative page setups.
AcSmSheetSet.SetName Method (SSO)
Returns S_FALSE without setting the Name property of the component. The Name property of the component should be changed at the component level.
AcSmSheetSet.SetOwner Method (SSO)
Sets the owner property of the IAcSmPersist object. The owning object should have a direct reference to this object.