About Creating and Editing Toolbars (VBA/ActiveX)
Using AutoCAD ActiveX/VBA you can create and edit toolbars within an existing menu group.
Topics in this section
About Creating New Toolbars (VBA/ActiveX)
To create a new toolbar, use the
Add
method to add a new
Toolbar
object to the
Toolbars
collection.
About Adding New Toolbar Buttons to a Toolbar (VBA/ActiveX)
To add a new toolbar button to a toolbar, use the
AddToolbarButton
method. This method creates a new
ToolbarItem
object and adds it to the designated toolbar.
About Adding Separators to a Toolbar (VBA/ActiveX)
To add a separator to a toolbar, use the
AddSeparator
method. This method creates a new
ToolbarItem
object and adds it to the designated toolbar.
About Defining the Toolbar Button Image (VBA/ActiveX)
To define the images to be used on a toolbar button, use the
SetBitmaps
and
GetBitmaps
methods.
About Creating Flyout Toolbars (VBA/ActiveX)
To add a flyout toolbar button to a toolbar, use the
AddToolbarButton
method. This method creates a new
ToolbarItem
object and adds it to the designated toolbar.
About Floating and Docking Toolbars (VBA/ActiveX)
Toolbars can be docked or floated programmatically.
About Deleting Toolbar Buttons from a Toolbar (VBA/ActiveX)
To remove toolbar buttons from a toolbar, use the
Delete
method found on the toolbar button. You should only delete buttons from a toolbar while the toolbar is visible.
About Exploring the Properties of Toolbar Items (VBA/ActiveX)
Using the properties of a
ToolbarItem
object, you can control the way it appears and behaves on a
Toolbar
object.
Related Concepts
About Creating New Toolbars (VBA/ActiveX)
About Adding New Toolbar Buttons to a Toolbar (VBA/ActiveX)
About Adding Separators to a Toolbar (VBA/ActiveX)
About Defining the Toolbar Button Image (VBA/ActiveX)
About Creating Flyout Toolbars (VBA/ActiveX)
About Floating and Docking Toolbars (VBA/ActiveX)
About Deleting Toolbar Buttons from a Toolbar (VBA/ActiveX)
About Exploring the Properties of Toolbar Items (VBA/ActiveX)
About the MenuBar and MenuGroups Collections (VBA/ActiveX)