You can change the characteristics of the VBA IDE using the Options dialog box.
To open the Options dialog box, click Tools menu Options.
The Options dialog box contains four tabs:
- Editor
- Editor Format
- General
- Docking
Editor Tab
The Editor tab specifies the Code window and Project window settings.
- Code settings include
-
- Auto Syntax Check
- Require Variable Declaration
- Auto List Member
- Auto Quick Info
- Auto Data Tips
- Auto Indent
- Tab Width
- Window settings include
-
- Drag and Drop Text Editing
- Default to Full Module View
- Procedure Separator Display
Editor Format Tab
The Editor Format tab specifies the appearance of your code.
You can
- Change color of the code
- Change text list items
- Change foreground
- Change background
- Change margin indicators
- Change text font and size
- Display or hide the margin indicator
- Display or hide sample text for your settings
General Tab
The General tab specifies the settings, error handling, and compile settings for your current VBA project.
You can
- Change the grid settings for the form grid
- Display or hide tooltips
- Set the automatic collapse of windows
- Choose to receive state loss notifications
- Determine how errors are handled
- Set the project to compile on demand or perform background compilations
Docking Tab
The Docking tab allows you to choose which windows you want to be dockable.