The following table provides summary descriptions of the AutoLISP ActiveX data conversion functions.
Data conversion functions |
|
---|---|
Function |
Description |
Creates an ActiveX-compatible 3D point structure |
|
Transforms entity to VLA-object |
|
(vlax-make-safearray type '(l-bound . u-bound) ['( l-bound . u-bound) ...]) |
Creates a safearray |
Creates a variant data type |
|
Stores elements in a safearray |
|
Returns the number of dimensions in a safearray object |
|
Returns an element from an array |
|
Returns the lower boundary (starting index) of a dimension of an array |
|
Returns the upper boundary (end index) of a dimension of an array |
|
Adds or updates an element in an array |
|
Returns the data type of a safearray |
|
Returns the elements of a safearray in list form |
|
Returns a suitable representation for a 4 x 4 transformation matrix to be used in VLA methods |
|
Returns the value of a variant after changing it from one data type to another |
|
Returns the data type of a variant |
|
Returns the value of a variant |
|
Transforms a VLA-object to an AutoLISP entity |