vlax-object-released-p (AutoLISP/ActiveX)

Determines if an object has been released

Supported Platforms: Windows only

Signature

(vlax-object-released-p obj)
obj

Type: VLA-object

An object.

Return Values

Type: T or nil

T, if the object is released (no AutoCAD drawing object is attached to obj); nil if the object has not been released.

Remarks

Note: Erasing a VLA-object (using command with the AutoCAD ERASE command or vla-erase) does not release the object. A VLA-object is not released until you invoke vlax-release-object on the object, or normal AutoLISP garbage collection occurs, or the drawing database is destroyed at the end of the drawing session.

Examples

Attach a Microsoft Excel application to the current AutoCAD drawing:

(setq excelobj (vlax-get-object "Excel.Application"))
#<VLA-OBJECT _Application 00168a54>

Release the Excel object:

(vlax-release-object excelobj)
1

Issue vlax-object-released-p to verify the object was released:

(vlax-object-released-p excelobj)
T