The following table provides summary descriptions of the AutoLISP curve measurement functions.
Curve measurement functions |
|
---|---|
Function |
Description |
Returns the area inside the curve |
|
Returns the point (in WCS coordinates) on a curve that is nearest to the specified point |
|
(vlax-curve-getClosestPointToProjection curve-obj givenPnt normal [extend]) |
Returns the closest point (in WCS) on a curve after projecting the curve onto a plane |
Returns the length of the curve's segment from the curve's beginning to the specified parameter |
|
Returns the length of the curve's segment between the curve's start point and the specified point |
|
Returns the parameter of the endpoint of the curve |
|
Returns the endpoint (in WCS coordinates) of the curve |
|
Returns the first derivative (in WCS coordinates) of a curve at the specified location |
|
Returns the parameter of a curve at the specified distance from the beginning of the curve |
|
Returns the parameter of the curve at the point |
|
Returns the point (in WCS coordinates) along a curve at the distance specified by the user |
|
Determines the point on the curve that corresponds to the param parameter and returns the point |
|
Returns the second derivative (in WCS coordinates) of a curve at the specified location |
|
Returns the start parameter on the curve |
|
Returns the start point (in WCS coordinates) of the curve |
|
Determines if the specified curve is closed (i.e., start point is same as endpoint) |
|
Determines if the specified curve has an infinite range in both directions and there is a period value dT, such that there is a point on curve at ( u + dT) = point on curve ( u), for any parameter u |
|
Determines if there is a plane that contains the curve |