The following table provides summary descriptions of the AutoLISP user input functions.
User input functions |
|
---|---|
Function |
Description |
Prompts the user to select a single object (entity) by specifying a point |
|
Pauses for user input of an angle, and returns that angle in radians |
|
Pauses for user input of a rectangle's second corner |
|
Pauses for user input of a distance |
|
Prompts the user for a file name with the standard AutoCAD file dialog box, and returns that file name |
|
Pauses for user input of an integer, and returns that integer |
|
Pauses for user input of a keyword, and returns that keyword |
|
Pauses for user input of an angle, and returns that angle in radians |
|
Pauses for user input of a point, and returns that point |
|
Pauses for user input of a real number, and returns that real number |
|
Pauses for user input of a string, and returns that string |
|
Establishes keywords for use by the next user input function call |
|
Prompts the user to select an object (entity) by specifying a point, and provides access to the definition data contained within a complex object |
|
Provides similar functionality to that of the nentsel function without the need for user input |