The following table provides summary descriptions of the AutoLISP symbol-handling functions.
Symbol-handling functions |
|
---|---|
Function |
Description |
Verifies that an item is an atom |
|
Returns a list of the currently defined symbols |
|
Verifies whether a value is bound to a symbol |
|
Verifies that an item evaluates to nil |
|
Verifies that an item is bound to nil |
|
Verifies that an item is a real or an integer |
|
Returns an expression without evaluating it |
|
Sets the value of a quoted symbol name to an expression |
|
Sets the value of a symbol or symbols to associated expressions |
|
Returns the type of a specified item |
|
Returns a string containing the name of a symbol |
|
Returns the current value bound to a symbol |
|
Identifies whether or not a specified object is a symbol |