princ (AutoLISP)

Prints an expression to the command line, or writes an expression to an open file

Supported Platforms: Windows and Mac OS

Signature

(princ [expr [file-desc]])
expr

Type: Integer, Real, String, List, Symbol, File, Subroutine, Ename (entity name), T, or nil

A string or AutoLISP expression. Only the specified expr is printed; no newline or space is included.

file-desc

Type: File or nil

A file descriptor for a file opened for writing.

Return Values

Type: Integer, Real, String, List, Symbol, File, Ename (entity name), T, or nil

The value of the evaluated expr. If called with no arguments, princ returns a null symbol.

Remarks

This function is the same as prin1, except control characters in expr are printed without expansion. In general, prin1 is designed to print expressions in a way that is compatible with load, while princ prints them in a way that is readable by functions such as read-line.

Examples

N/A