The following table provides summary descriptions of the AutoLISP string-handling functions.
String-handling functions |
|
---|---|
Function |
Description |
Returns the first list or atom obtained from a string |
|
Returns a string where all alphabetic characters have been converted to uppercase or lowercase |
|
Returns a string that is the concatenation of multiple strings |
|
Returns an integer that is the number of characters in a string |
|
Returns a substring of a string |
|
Returns the string representation of any LISP object as if it were output by the prin1 function |
|
Returns the string representation of any LISP object as if it were output by the princ function |
|
Converts a string into a list of Unicode character codes |
|
Returns the Unicode representation of the character at a specified position in a string |
|
Removes the specified characters from the beginning of a string |
|
Returns the length of the longest common prefix for two strings, starting at specified positions |
|
(vl-string-position char-code str [ start-pos [from-end-p]]) |
Looks for a character with the specified Unicode code in a string |
Removes the specified characters from the end of a string |
|
Searches for the specified pattern in a string |
|
Substitutes one string for another, within a string |
|
Replaces characters in a string with a specified set of characters |
|
Removes the specified characters from the beginning and end of a string |
|
Performs a wild-card pattern match on a string |