Calls the specified ActiveX method
Supported Platforms: Windows only
(vlax-invoke-method obj method arg [arg ...])
Type: VLA-object
An object.
Type: Symbol or String
A symbol or string naming the method to be called.
Type: Integer, Real, String, List, VLA-object, Variant, Safearray, T, or nil
Argument to be passed to the method called. No argument type checking is performed.
Type: Integer, Real, String, List, VLA-object, Variant, Safearray, T, or nil
Depends on the method invoked.
This function was known as vlax-invoke prior to AutoCAD 2000.
The following example uses the AddCircle method to draw a circle in the current AutoCAD drawing.
The first argument to AddCircle specifies the location of the center of the circle. The method requires the center to be specified as a variant containing a three-element array of doubles. You can use vlax-3d-point to convert an AutoLISP point list to the required variant data type:
(setq circCenter (vlax-3d-point '(3.0 3.0 0.0))) #<variant 8197 ...>
Now use vlax-invoke-method to draw a circle with the AddCircle method:
(setq mycircle (vlax-invoke-method mspace 'AddCircle circCenter 3.0)) #<VLA-OBJECT IAcadCircle 00bfd6e4>