Reactor functions define, query, and delete reactors and reactor properties. Before you can use these functions, you must load AutoLISP reactor support by issuing the following function:
(vl-load-com)
The vl-load-com function initializes reactor support and a number of other AutoLISP extensions.
Reactor functions |
|
---|---|
Function |
Description |
Loads AutoLISP reactor support functions and other AutoLISP extensions |
|
Constructs a database (global) reactor object |
|
Enables a disabled reactor object |
|
Tests to determine whether a reactor object is enabled |
|
Produces a beep sound |
|
Constructs an editor reactor that notifies of a command event |
|
Returns the name (symbol) of the current event, if called from within a reactor's callback |
|
Returns application-specific data associated with a reactor |
|
Overwrites application-specific data associated with a reactor |
|
Constructs an editor reactor object that provides notification of deep clone events |
|
Constructs a reactor object that provides notification of MDI-related events |
|
Constructs an editor reactor object that provides notification of a drawing event (for example, opening or closing a drawing file) |
|
Constructs an editor reactor object that notifies of an event related to reading or writing of a DXF file |
|
Constructs an editor (global) reactor object |
|
Constructs an editor reactor object that notifies of an event related to block insertion |
|
Constructs a linker (global) reactor object |
|
Constructs an editor reactor object that notifies of a LISP event |
|
Constructs an editor reactor object that does not fall under any of the other editor reactor types |
|
Constructs an editor reactor object that provides notification of a mouse event (for example, a double-click) |
|
Determines whether or not a reactor's callback function will execute if its associated namespace is not active |
|
Constructs an object reactor object |
|
Adds an object to the list of owners of an object reactor |
|
Removes an object from the list of owners of an object reactor |
|
Returns the list of owners of an object reactor |
|
Makes a reactor persistent |
|
Returns a list of persistent reactors in the current drawing |
|
Determines whether or not a reactor is persistent |
|
Makes a reactor transient |
|
Returns a list of all callback conditions for this reactor type |
|
Adds or replaces a callback function in a reactor |
|
Returns a list of pairs ( event-name . callback_function) for the reactor |
|
Returns a list of reactors of the specified types |
|
Disables a reactor |
|
Disables all reactors of the specified type |
|
Defines whether or not a reactor's callback function will execute if its associated namespace is not active |
|
Constructs an editor reactor object that provides notification of a change to a system variable |
|
Constructs an editor reactor object that provides notification of a change to the bitmaps in a toolbar |
|
A pre-defined callback function that prints one or more callback arguments in the Trace window |
|
Returns a symbol representing the reactor type |
|
Returns a list of all reactor types |
|
Constructs an editor reactor object that provides notification of an undo event |
|
Constructs an editor reactor object that provides notification of an event related to writing a block |
|
Constructs an editor reactor object that notifies of an event related to moving or sizing an AutoCAD window |
|
Constructs an editor reactor object that provides notification of an event related to attaching or modifying XREF |