vlax-ldata-test (AutoLISP/ActiveX)

Determines if data can be saved over a session boundary

Supported Platforms: Windows only

Signature

(vlax-ldata-test data)
data

Type: Integer, Real, String, List, Ename (entity name), VLA-object, Variant, Safearray, T, or nil

Any LISP data to be tested.

Return Values

Type: T or nil

T, if the data can be saved and restored over the session boundary; otherwise nil.

Examples

Determine if a string can be saved as ldata over a session boundary:

(vlax-ldata-test "Gumbo jumbo")
T

Determine if a function can be saved as ldata over a session boundary:

(vlax-ldata-test yinyang)
nil