The following table provides summary descriptions of the AutoLISP file-handling functions.
File-handling functions |
|
---|---|
Function |
Description |
Closes an open file |
|
Searches the AutoCAD library path for the specified file |
|
Searches the AutoCAD trusted file paths for the specified file |
|
Opens a file for access by the AutoLISP I/O functions |
|
Returns the decimal ASCII code representing the character read from the keyboard input buffer or from an open file |
|
Reads a string from the keyboard or from an open file |
|
Lists all files in a given directory |
|
(vl-file-copy "source-filename" "destination-filename" [append]) |
Copies or appends the contents of one file to another file |
Deletes a file |
|
Determines if a file name refers to a directory |
|
Renames a file |
|
Determines the size of a file, in bytes |
|
Returns last modification time of the specified file |
|
Returns the name of a file, after stripping out the directory path and extension |
|
Returns the directory path of a file, after stripping out the name and extension |
|
Returns the extension from a file name, after stripping out the rest of the name |
|
Calculates a unique file name to be used for a temporary file |
|
Writes one character to the screen or to an open file |
|
Writes a string to the screen or to an open file |