The following table provides summary descriptions of the AutoLISP query and command functions.
Query and command functions |
|
---|---|
Function |
Description |
Displays the standard AutoCAD Color Selection dialog box |
|
Invokes the Help facility (obsolete) |
|
Executes an AutoCAD command |
|
Executes an AutoCAD command and the supplied input |
|
Retrieves application data from the AppData section of the acadXXXX.cfg file |
|
Retrieves the localized or English name of an AutoCAD command |
|
Returns the string value assigned to an environment variable |
|
Retrieves the value of an AutoCAD system variable |
|
Invokes the Help facility |
|
Writes application data to the AppData section of the acadXXXX.cfg file |
|
Sets an environment variable to a specified value |
|
Registers a user-defined command with the Help facility so the appropriate help file and topic are called when the user requests help on that command |
|
Sets an AutoCAD system variable to a specified value |
|
Returns a string that contains the current AutoLISP version number |
|
Executes an AutoCAD command after evaluating arguments |
|
Adds commands to a group Note: Extended AutoLISP extension: requires
vl-load-com
|
|
Removes a single command or command group Note: Extended AutoLISP extension: requires
vl-load-com
|