General Format

The command line interface should use a standard format. The general format or syntax of the command line should be as follows:

Description: Setting1=Value Setting2=Value Setting3=Value

Current instruction (descriptive info) or [Option1/oPtion2/opTion3/...] <default option>:

The optional command line that displays current settings is called the current value line. The required command line that provides specific instructions and displays available options is called the command line prompt.

The command line parser uses a set of special characters to correctly populate the context menus. These special characters cannot be used anywhere in the command line interface except as noted below.

Special characters in the command line interface

   

Symbol

Name

Function in the command prompt

:

Colon

Used to end the prompt string or after the description part of the current value line

[

Left square bracket

Indicates the start of command options

]

Right square bracket

Indicates the end of command options

<

Left angle bracket

Indicates the start of the default option

>

Right angle bracket

Indicates the end of the default option

Option keywords must be enclosed in square brackets and separated by forward slashes. If a set of parentheses is included in an option string, the parentheses must contain that entire option string as it appears in English.

There can be more than one word between slashes, but only one word must contain one or more capitalized letters that indicate the keyboard shortcut. Multiple capitalized letters must be grouped together and can appear at any location within a word. If a number appears before a capitalized letter, it is also part of the keyboard shortcut. The word that contains the capitalized letters is, by definition, the keyword. Users can enter the entire keyword or the keyboard shortcut to issue an option.

Most commands require one command line prompt. Some will be preceded by a current value line. In some cases, a prompt is split between two lines, or two prompts are issued for the same command. For example, the prompt for ZOOM looks like this:

Command: zoom

Specify corner of window, enter a scale factor (nX or nXP), or

[All/Center/Dynamic/Extents/Previous/Scale/Window/Object] <real time>:

In this case, one prompt is split, which results in two lines.

The EXTEND command has a value line and two prompts.

Command: extend

Current settings: Projection=UCS, Edge=None

Select boundary edges ...

Select objects or <select all>:

The default setting for the command line window is three lines; therefore, prompts for native commands are no more than three lines. External developers are advised to adhere to this limit as well.

Prompts should be designed to wrap before the 80th character. The line break should occur at one of the following locations:

No other wrapping locations are acceptable.

Our target display for measuring the above conditions is an 800 x 600 monitor.