分离和附加 UV

在“UV 编辑器”(UV Editor)中,Maya 提供了多个用于分离、合并和附加 UV 的功能。这些功能对于许多操作十分重要:
目标 操作 示例

沿选定边分离(切割)UV 壳。

  1. 选择要分离的边。
  2. 选择“切割/缝合 > 切割”(Cut/Sew > Cut),或在“UV 工具包”(UV Toolkit)中选择“切割和缝合 > 切割”(Cut and Sew > Cut)(快捷方式:Shift + X)。

以交互方式分离(切割) UV 边

在 UV 编辑器中分离 UV 边

  1. 选择“工具 > 切割”(Tools > Cut),或在“UV 工具包”(UV Toolkit)中选择“切割和缝合 > 切割工具”(Cut and Sew > Cut Tool)

  2. 沿边拖动以将其分离。

在视口中分离 UV 边

  1. 选择“UV > 3D 切割和缝合 UV 工具”(UV > 3D Cut and Sew UV Tool)。
  2. 沿边拖动以将其分离。

    有关详细信息(包括快捷方式的列表),请参见 3D 切割和缝合工具。

允许 Maya 分离(切割)边(或选择接缝边)

  1. 选择一个 UV 壳。
  2. 在“UV 编辑器”(UV Editor)的“UV 工具包”(UV Toolkit)中,选择“切割/缝合 > 自动接缝”(Cut/Sew > Auto-Seams)。

    根据当前的“自动接缝”(Auto-Seams)选项,接缝将被切割为网格或在不进行切割的情况下被选中。

沿选定边附加(缝合)UV 壳。

  1. 选择要附加的边。
  2. 选择“切割/缝合 > 缝合”(Cut/Sew > Sew),或在“UV 工具包”(UV Toolkit)中选择“切割和缝合 > 缝合”(Cut and Sew > Sew)(快捷方式:Shift + S)。

以交互方式附加(缝合)UV 边

在 UV 编辑器中缝合 UV 边

  1. 选择“工具 > 缝合”(Tools > Sew),或在“UV 工具包”(UV Toolkit)中选择“切割/缝合 > 缝合工具”(Cut/Sew > Sew Tool)

  2. 沿边拖动以将其附加。

在视口中缝合 UV 边

  1. 选择“UV > 3D 切割和缝合 UV 工具”(UV > 3D Cut and Sew UV Tool)。
  2. 按住 Shift 键并沿边拖动以将其附加。

    有关详细信息(包括快捷方式的列表),请参见 3D 切割和缝合工具。

注: 在“视口”(Viewport)和“UV 编辑器”(UV Editor)之间移动时,“3D 切割和缝合 UV 工具”(3D Cut and Sew UV Tool)将自动更改为“切割工具”(Cut Tool)。

沿选定边附加(缝合)UV 壳并一起移动壳。

  1. 选择要附加的边。
  2. 在“UV 工具包”(UV Toolkit)中选择“切割/缝合 > 缝合到一起”(Cut/Sew > Stitch Together) > 。

合并选定 UV。

  1. 选择要合并的 UV。
  2. 选择“修改 > 合并”(Modify > Merge)。

“合并 UV”(Merge UVs)仅合并共享相同的顶点的 UV。可以为 Maya 将移动 UV 以合并它们的最大距离指定一个选项。

自动附加并移动小壳。

  1. 选择所有壳。
  2. 选择“切割/缝合 > 移动并缝合”(Cut/Sew > Move and Sew) > 。
  3. (可选)启用“限制壳大小”(Limit Shell Size),然后为 UV 壳设置最大大小(以面数表示)。将不会移动大于该数字的壳。
  4. 单击“应用”(Apply)。

在执行“移动并缝合”(Move and Sew)操作之后,可以选择该节点 (polyMapSewMove),然后在“属性编辑器”(Attribute Editor)或“通道盒”(Channel Box)中编辑它来调整“面数”(Number Faces)。

注释