This section provides tables that group the Properties palette APIs into functional categories.
Object Wrapping Interfaces and Classes |
|
---|---|
Interface or Class |
Purpose |
IAcadBaseObject |
Basic object protocol for database-resident objects |
IAcadBaseObjectImpl |
IDispatch-based template class that instantiates objects derived from IAcadBaseObject |
IAcadBaseObject2 |
Basic object protocol for non-database-resident objects |
IAcadBaseObject2Impl |
IDispatch-based template class that instantiates objects derived from IAcadBaseObject2 |
AcAxObjectRef |
Abstracts a reference to an AcDbObject instance so that it can be either database-resident or non-database-resident |
AcAxObjectRefPtr |
Provides smart-pointer support for AcAxObjectRef instances |
CProxy_PropertyNotifySink |
Template class that facilitates notification of connected objects when a COM wrapper object is modified |
Properties Palette Interfaces |
|
---|---|
Interface |
Purpose |
IAcPpPaletteSet |
Controls Properties palette tabs |
IAcPpPaletteSetEvents |
Notifies when the Properties palette's tab set changes |
IAcPpPalette |
Provides access to a single Properties palette tab |
IAcPpPaletteEvents |
Notifies when a Properties palette tab's state changes |
Property Display Interfaces |
|
---|---|
Interface |
Purpose |
ICategorizeProperties |
Categorizes properties |
IAcPiCategorizeProperties |
Categorizes properties; supports nested categories and dynamic properties |
IOPMPropertyDialog |
Associates a dialog with the ellipsis button that represents a property of a database-resident object |
IOPMPropertyDialog2 |
Associates a dialog with the ellipsis button that represents a property of any COM object |
IDynamicEnumProperty |
Used by dynamic properties to create an enumerated property that is displayed as a drop-down list in the Property Inspector |
IDynamicProperty |
Defines a single dynamic property for database-resident objects |
IDynamicProperty2 |
Defines a single dynamic property for any COM object |
IDynamicPropertyNotify |
Notifies when a dynamic property changes |
IDynamicPropertyNotify2 |
Notifies when a dynamic property for a COM object changes |
IOPMPropertyExpander |
Allows a static property to expand into sub-properties |
IOPMPropertyExpander2 |
Extends IOPMPropertyExpander functionality to dynamic properties |
IOPMPropertyExtension |
Controls miscellaneous display and editing attributes of a property |
IPerPropertyBrowsing |
Microsoft-defined interface for associating property sheets with properties |
IPropertyManager |
Manages dynamic properties of an AcRxClass |
IPropertyManager2 |
Manages dynamic properties for any COM object |
ITypeInfo |
Microsoft-defined interface for discovering static properties |
IAcPiPropertyDisplay |
Customizes the display on a per-property basis |
IAcPiPropCommandButtons |
Places command buttons on the Property Inspector UI |
IIAcPiCommandButton |
Defines a Property Inspector command button |
IAcPiPropertyUnspecified |
Defines properties that have no default value |
IPropertyNotifySink |
Microsoft-defined interface used by properties to notify Property Inspectors that the property has changed; automatically implemented for wrappers derived from IAcadBaseObjectImpl |
Property Inspector Interfaces |
|
---|---|
Interface |
Purpose |
IAcPiPropertyInspector |
Provides access to the Property Inspector control |
IAcPiPropertyInspectorSink |
Notifies that a property's display and/or value has changed |
Property Edit Control Interfaces |
|
---|---|
Interface |
Purpose |
IAcPiPropertyEditControl |
Defines an ActiveX control that may be hosted by the Property Inspector |
IAcPiPropertyEditEventsSink |
Allows a hosted control to communicate with the Property Inspector |
IAcPeNumericEditor |
Allows the Property Inspector to initialize and invoke hosted numeric editor controls |
IAcPeNoPickVariantRW |
Allows the Property Inspector to initialize a variant control's read/write attribute |
IAcPeVariantCtrl |
Allows the Property Inspector to initialize and invoke hosted variant editor controls |
IAcPeButtonEditCtrl |
Allows the Property Inspector or a static or dynamic property to initialize and invoke button controls |
IAcPePick2PointsCtrl |
Allows third-party applications to control aspects of the point-picking mechanism |
Per-Instance Dynamic Property Interfaces |
|
---|---|
Interface |
Purpose |
IPropertySource |
Provides dynamic properties for a single instance of a COM object |
OPMPerInstancePropertySources |
Maps dynamic property sources by name |
OPMPerInstancePropertyExtension |
Lists property source names associated with a single AcRxClass instance |
OPMPerInstancePropertyExtensionFactory |
Associates OPMPerInstancePropertyExtension instances with AcRxClass instances |
Property Inspector Hosting Interface |
|
---|---|
Interface or Class |
Purpose |
IAcPiPropertyInspectorInputEventSink |
Allows the Property Inspector to communicate with its host |