PowerMill Viewer の概要

PowerMill Viewer は、追加費用なしで複数のコンピュータ上で実行できる、機能制限付きのアプリケーションです。

注: PowerMill Viewer は、PowerMill 2020.2 以降に更新した場合にのみインストールに含まれます。

PowerMill Viewer を使用すると、既存の PowerMill プロジェクトを開き、確認、シミュレーション、および検証することができます。重要な点として、PowerMill Viewer は、プロジェクト、ツールパス、モデル、バウンダリー、パターンなどの主なデータを保存またはエクスポートすることができません。また、PowerMill Viewer は、NC プログラムのポストプロセス、セットアップ シートの生成、マクロの作成、または COM での作業も行うことができません。

一般的な活用事例

PowerMill Viewer は、さまざまな方法で使用することができます。たとえば、次のように使用されます。
  • PowerMill プロジェクトを CNC マシンで実行する前にチェックするマシン オペレーター。これらのチェックには、モデルやブロックのサイズ、データムの位置、送り / 速度の確認に加え、ツールパスの検証による干渉の識別、工具長さの検証などが含まれます。
  • 加工サイクル回数の試算や生産計画を支援するために PowerMill プロジェクトの概要を必要としているプロジェクト マネージャーまたはオペレーション マネージャー。
  • 新規ビジネスの調査の際、試算のために PowerMill Viewer を使用する営業担当者。

PowerMill Viewer の起動

  1. ご使用のコンピュータに PowerMill 2020.2 以降がインストールされていることを確認します。
    注: 複数のコンピュータで PowerMill Viewer を実行する場合、まず各コンピュータに PowerMill をインストールする必要があります。
  2. Windows の スタート メニューまたは スタート 画面を開きます。
  3. [Autodesk PowerMill] > [Autodesk PowerMill Viewer] をクリックします。
ヒント: 最新の PowerMill の更新プログラムは、Autodesk Account または Autodesk デスクトップ アプリからダウンロードしてインストールすることができます。

制限された機能

PowerMill Viewer では、次の機能は使用できません。

ファイル タブのコマンド

  • [ファイル] タブ > [情報] > [ファイルに設定保存]
  • [ファイル] タブ > [開く] > [アーカイブ プロジェクト]
  • [ファイル] タブ > [名前を付けて保存] > [プロジェクト]
  • [ファイル] タブ > [名前を付けて保存] > [アーカイブ プロジェクト]
  • [ファイル] タブ > [名前を付けて保存] > [テンプレート オブジェクト]
  • [ファイル] タブ > [インポート] > [アーカイブ プロジェクト]
  • [ファイル] タブ > [エクスポート] > [モデル エクスポート]
  • [ファイル] タブ > [オプション] > [インストール済みプラグイン管理]

ホーム タブのコマンド

  • [ホーム] タブ > [マクロ] > [記録]

バウンダリー タブのコマンド

  • [バウンダリー] タブ > [ファイル] > [エクスポート]

パターン タブのコマンド

  • [パターン] タブ > [ファイル] > [エクスポート]

孔フィーチャー セット タブのコマンド

  • [孔フィーチャー セット] タブ > [ファイル] > [エクスポート]

ストック モデル タブのコマンド

  • [ストック モデル] タブ > [ファイル] > [エクスポート]

マシン タブのコマンド

  • [マシン] タブ > [ファイル] > [エクスポート]

シミュレーション タブのコマンド

  • [シミュレーション] タブ > [ViewMill] > [エクスポート]

NC プログラム タブのコマンド

  • [NC プログラム] タブ > [ポスト] > [書出し]
  • [NC プログラム] タブ > [セットアップ シート] > [プロジェクト] > [現行ビュー スナップショット]
  • [NC プログラム] タブ > [セットアップ シート] > [プロジェクト] > [スナップショット プレビュー]
  • [NC プログラム] タブ > [セットアップ シート] > [プロジェクト] > [全てプレビュー]
  • [NC プログラム] タブ > [セットアップ シート] > [プロジェクト] > [全てエクスポート]
  • [NC プログラム] タブ > [セットアップ シート] > [NC プログラム] > [スナップショット プレビュー]
  • [NC プログラム] タブ > [セットアップ シート] > [NC プログラム] > [プレビュー]
  • [NC プログラム] タブ > [セットアップ シート] > [NC プログラム] > [エクスポート]
  • [NC プログラム] タブ > [セットアップ シート] > [NC プログラム] > [現行ビュー]
  • [NC プログラム] タブ > [セットアップ シート] > [ツールパス] > [現行ビュー]
  • [NC プログラム] タブ > [セットアップ シート] > [ツールパス] > [状態ビュー]
  • [NC プログラム] タブ > [セットアップシート] > [ツールパス] > [アイソメ ビュー]

ビュー タブのコマンド

  • [ビュー] タブ > [ユーティリティ] > [スクリーンショット]

ダイアログのコマンド

  • [製品情報] ダイアログ > [ライセンス管理]
  • [カスタマイズ - 色] ダイアログ > [色テーブル エクスポート]
  • [NC プログラム] ダイアログ > [書出し]
  • [プローブ ツール] ダイアログ > [工具ステム保存]
  • [プローブ ツール] ダイアログ > [プローブ ボディ保存]
  • [ストラテジー保存] ダイアログ > [保存]
  • [スライス編集] ツールバー > [ピクチャとしてスライス保存]
  • [工具アセンブリ プレビュー] ダイアログ > [エクスポート]
  • [工具データベース エクスポート] ダイアログ > [新規ストック素材定義]
  • [工具] ダイアログ > [工具プロファイル保存]
  • [工具] ダイアログ > [工具シャンク保存]
  • [工具] ダイアログ > [工具ホルダー保存]

右クリック メニューのオプション

  • [マシン] > [マシン エクスポート]
  • [NC プログラム] > [全て書出し]
  • [NC プログラム] > [セットアップ シート] > [プロジェクト スナップショット] > [現行ビュー]
  • [NC プログラム] > [セットアップ シート] > [プロジェクト スナップショット] > [プレビュー]
  • [NC プログラム] > [セットアップ シート] > [全てプレビュー]
  • [NC プログラム] > [セットアップ シート] > [全てエクスポート]
  • [NC プログラム] > [書出し]
  • [NC プログラム] > [選択書出し]
  • [NC プログラム] > [セットアップ シート] > [スナップショット] > [現行ビュー]
  • [NC プログラム] > [セットアップ シート] > [スナップショット] > [プレビュー]
  • [NC プログラム] > [セットアップ シート] > [スナップショット] > [全ツールパス] > [現行ビュー]
  • [NC プログラム] > [セットアップ シート] > [スナップショット] > [全ツールパス] > [現行状態ビュー]
  • [NC プログラム] > [セットアップ シート] > [スナップショット] > [全ツールパス] > [アイソメ ビュー]
  • [NC プログラム] > [セットアップ シート] > [プレビュー]
  • [NC プログラム] > [セットアップ シート] > [選択プレビュー]
  • [NC プログラム] > [セットアップ シート] > [エクスポート]
  • [NC プログラム] > [セットアップ シート] > [選択エクスポート]
  • [バウンダリー] > [保存]
  • [パターン] > [保存]
  • [孔フィーチャー セット] > [エクスポート]
  • [孔フィーチャー セット] > [エクスポート]
  • [モデル] > [全てエクスポート]
  • [モデル] > [モデル エクスポート]
  • [ストック モデル] > [エクスポート]
  • [マクロ] > [記録]

Other

  • COM を使用してコマンドを実行する