Troubleshoot Proxy

Symptoms: A deployment step fails and logs show that TLS connections cannot be established due to a rejected certificate.

You may see messages such as "SSLCertVerificationError" or "SSL: Certificate_Verify_Failed".

Root Cause:

Companies that use proxies will distribute a new trusted certificate to all administered machines. Most web browsers will automatically detect the new certificate, but not all applications reference the same keystore.

Greengrass depends on Java KeyStore for trusted certificates. Java is bundled in with the Greengrass MSI, and is likely missing the company-specific proxy certificate.

Solution:

First, identify and obtain a copy of your company-specific proxy certificate. You can:

Next, configure Greengrass to trust the HTTPS proxy:

  1. Add the contents of your certificate file to both of these root CA certificate files:
    • C:\greengrass\v2\tenant\rootCA.pem (or wherever your Greengrass working directory is located)
    • C:\Program Files\Autodesk\Info360\customer-configs-1.0.0\rootCA.pem
  2. Restart the Greengrass service.

See also: AWS documentation - Connect on port 443 or through a network proxy