Remote Queue offline

Problem

A remote machine that was added in the Analyze dialog displays the message offline.

Cause

What to do

To check the service is running on the remote machine

  1. Open the Windows Services application.

  2. Click on Autodesk Simulation Compute Manager.

  3. If the Status is not shown as Running, restart the service by clicking the Restart or Start button.

  1. Issue the command ps -eaf | grep SimulationCompute in a terminal. Four processes bearing the name SimulationCompute should be present and running with the following information present in their respective command line:
  1. If ANY of the above is not true, stop any existing Simulation Compute Manager daemon by killing the PID specified in the --pidfilename argument used to start the daemon.

  2. Allow sufficient time for the processes to exit cleanly.

  3. Make sure the SimulationCompute processes are terminated by calling /sbin/pidof SimulationCompute. If a process IDs are returned, kill the all processes using kill -9 '<process ID>'.

  4. Restart the service by running $INSTALL_ROOT/opt/Autodesk/simulation-compute/bin/SimulationCompute.

  1. Check the status of the service by issuing the command: systemctl status adskscm.

  2. If the status is not active (running) restart the service by issuing the command sudo systemctl restart adskscm.

To open the port in the firewall settings

  1. Issue the command firewall-cmd --permanent --add-port=43100/tcp.

  2. Issue the command firewall-cmd --reload.