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This reference and troubleshooting guide gives you, a print service provider, the infor-
mation you need to obtain consistent, high-quality output from files containing objects 
created with the transparency features in Adobe® professional publishing products. 
Design professionals, customer support specialists, and OEMs who require a deeper 
understanding of transparency in the print production process will find this guide 
helpful. This guide explains how transparency is processed (flattened) when exporting 
or printing documents, how flattening affects your workflow, and the controls Adobe 
applications provide for flattening transparency. This guide does not explain the ways a 
designer may use transparency to achieve distinctive creative effects, nor how each ap-
plication provides controls for design purposes. The user guide and online help for each 
specific application should be consulted for tips on creating designs using transparency 
effects. Please read the companion document to this one, “A Designer’s Guide to Trans-
parency for Print Output.”

Chapters in this guide
Chapter 1: An Overview of Transparency in Adobe Applications—This chapter briefly 
describes transparency, flattening, and how transparency can affect your workflow.

Chapter 2: Flattening Basics—This chapter discusses basic steps and information you 
should know when working with or processing files that contain transparency from 
Adobe professional publishing products.

Chapter 3: Controlling the Flattener—This chapter describes how to effectively use 
the controls in Adobe professional publishing products for managing transparency and 
flattening. This chapter also discusses how the use of transparency in files can affect 
your production workflows.

Chapter 4: Transparency and Color—This chapter discusses how the Transparency 
Flattener interacts with color elements (spot color, process colors, and color manage-
ment) in jobs that contain transparency.

Chapter 5: Best Practices—This chapter discusses various strategies for: detecting live 
transparency by using the Flattener Preview, using Flattener settings to determine the 
elements that are affected by flattening, and configuring the Flattener settings before 
you perform the flattening.

Chapter 6: Flattening Controls in Illustrator CS2—This chapter describes specific 
information about transparency and flattening controls for Illustrator CS2.

Chapter 7: Flattening Controls in InDesign CS2—This chapter describes specific 
information about transparency and flattening controls for InDesign CS2.

Chapter 8: Flattening Controls in Acrobat 7 Professional—This chapter describes spe-
cific information about transparency and flattening controls for Acrobat 7 Professional.

Chapter 9: Troubleshooting—This chapter describes in-depth how-to information 
about specific print output issues you might encounter in jobs that have transparent 
content. This chapter also includes specific known issues about transparency flattening 
and output devices.

Glossary: This chapter defines common terms used when discussing transparency and 
transparency flattening.

Products covered in this guide
This guide covers the following  
professional publishing products:

• Adobe Illustrator® CS2

• Adobe InDesign® CS2 

• Adobe Photoshop® CS2 

• Adobe Acrobat® 7 Professional 

• Adobe Creative Suite

• Adobe Acrobat Distiller® 

• Adobe Reader® 

• OpenType™ 

• Adobe Extreme® 3 (Extreme 3 is a high-end 
printing component integrated into systems 
sold and supported by Adobe original equip-
ment manufacturers.)

• Adobe PostScript® 3™ RIPs with direct PDF 
printing support (release 3015+) [Level 3 RIPs 
are licensed by Adobe and integrated into 
systems sold and supported by Adobe OEMs.]

Transparency in Adobe 
Applications:  
A Print Production Guide



Transparency in Adobe Applications: 2 
A Print Production Guide

Chapter 1: An Overview of Transparency in Adobe Applications
For many designers, creating transparent objects is not a new option. Transparency has been 
available in Adobe publishing software for several years. However, in the early days of desktop 
publishing, illustration and page layout programs let users create only opaque objects. Special 
effects, such as transparent overlays and soft drop shadows, required either a dedicated image-
editing program, such as Adobe Photoshop, which at the time required page layout artists to 
flatten Photoshop layers and transparency and export files to nonnative formats (EPS and TIFF) 
or manual prepress work that incurred added expense. Today, Illustrator CS2, InDesign CS2, 
Photoshop CS2, and Acrobat 7 Professional natively offer transparency features and controls for 
print publishing.

Transparency defined
Transparency is an effect applied to an object causing it to appear transparent and letting objects 
underneath show through. A common example of transparency is drop shadows. Transparency 
may be applied to an object in a number of ways in Adobe publishing applications.

Transparency terminology
Transparency introduces a number of terms with which you may not be familiar. This guide 
defines terms as they are addressed, but if you skip around, you may come across an unfamiliar 
term. Most terms are defined in the “Glossary” at the end of the guide.

Transparency options present prepress challenges
The need to handle transparency and transparency-based effects (such as drop shadows, blur 
effects, glow effects, and others) for images, text, and line art is standard practice in high-end 
prepress environments. You are probably familiar with handling transparency in Photoshop 
files; however, the transparency features offered in Illustrator CS2, InDesign CS2, and Acrobat 7 
Professional may be new to you.

Adobe has implemented a transparency model that lets graphic designers apply transparency 
and transparency-based effects to all objects in a document—including text, vectors, gradients, 
and imported graphics. If your company receives files created by the Adobe Creative Suite ap-
plications, you are probably receiving jobs with transparent design elements. However, if you are 
new to the Adobe transparency model, this document will help you understand the transparency 
technology used by the Adobe Creative Suite applications.

Optimized Adobe workflows that use transparency effects
The Adobe transparency model lets users optimize certain existing workflow practices. For 
instance, in the past you may have used Photoshop software to add drop shadows and vignettes 
to images. With transparency-aware tools, such as Illustrator CS2 or InDesign CS2, you can 
apply transparency effects directly to any objects in the file. In addition, these effects remain as 
live transparency so that when type is edited, for example, the applied drop shadow changes with 
it; it’s not necessary to return to Photoshop to make simple changes or to manage the results as a 
separate raster file. 

To make the most of Adobe publishing software transparency features, your current workflow 
may need to be altered. Most output problems can be avoided by reviewing this guide.

The rest of this chapter presents an overview about how to create transparency in Adobe publish-
ing applications.

Adding transparency
Adobe publishing software applies transparency in a number of different ways. In Illustrator or 
InDesign, you can apply transparency directly to an object by setting its opacity to something 
other than 100% using the Transparency palette. Another way you can apply transparency 
to objects is through blending modes—something you may be familiar with in Photoshop or 
Illustrator. When a blending mode other than Normal is applied to one or more overlapping 
objects, you can create striking visual effects that require the use of flattening to be reproduced 
for printing.

Transparency workflows
See the “Best practices“ chapter for information 
about how transparency may affect your production 
workflow.
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Blending modes: These three images are created from the same Illustrator artwork. The only difference 
is that the blue and purple pinwheel blades have been set to different blending modes: normal, multiply, 
and difference.

Transparency can also appear in other, less obvious, ways. You may introduce transparency as 
a side effect of using live effects or styles and brushes that contain live transparency. Designers 
may introduce transparency when they incorporate previously created content that contains live 
transparency—either by directly importing it or by means of the Clipboard.

The need to flatten transparent objects
The challenge with transparency is reproducing transparent effects in printed output or in ex-
ported file formats that do not support live transparency. To reproduce these effects, transparent 
objects and those that interact with them must be flattened.

The flattening process
At its simplest, the process of flattening converts all of the overlapping and interacting elements 
in a group of transparent objects into a collection of opaque elements that result in the same 
appearance as the original. This process is further detailed in the “Flattening process explained” 
section in Chapter 2.

You cannot modify the transparency effects in flattened files by using the source application 
nor any application into which you import the flattened file. To make changes to transparent 
objects (or those that interact with them), you must edit them in an unflattened version of the 
file—typically in the source application.

The Flattener
In Adobe publishing software that supports transpar-
ency, the mechanism that does the flattening is called 
the Transparency Flattener (often referred to as the 
Flattener). 
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Chapter 2: Flattening Basics
Flattening transparency accurately reproduces—by using opaque objects—the visual effect of 
transparency on printed output or in exported file formats that don’t support live transparency. 
The Transparency Flattener (Flattener) in Adobe publishing applications performs the conver-
sion. You control the way the Flattener works by configuring its settings based on the output 
requirements of the job.

Types of transparency
Transparency in Adobe publishing applications is referred to as either live or flattened. As a gen-
eral rule, files that contain live transparency are more desirable due to their device independence 
and the ease with which they can be edited. 

Live transparency
The transparency attributes of objects created in Adobe publishing applications stay live and 
fully editable while in their native applications. While not editable, transparency will remain 
live in non-native applications that support the native file format (such as PDF 1.4, 1.5, and 1.6). 
Transparency attributes are considered live because they can interact with objects that are placed 
beneath them, allowing those objects to show through the transparency. The use of live transpar-
ency in a file gives it a very high degree of device independence because the transparent elements 
are maintained as vector art rather than raster images with a fixed resolution.

The following file formats can contain live transparency:

• .AI: Adobe Illustrator 9, 10, CS, and CS2

• .INDD: Adobe InDesign 2, CS, and CS2

• .PSD: Adobe Photoshop 6, 7, CS, and CS2

• .PDF: Adobe PDF 1.4, 1.5, and 1.6 (Acrobat 5, 6, and 7)

• .TIFF: Version 6 (TIFF files saved from Photoshop 6 or later)

Flattened transparency
Transparency is flattened when a file containing live transparency is converted into a format that 
doesn’t support live transparency or the file is printed. Conversion is the job of the Flattener. 
During the flattening process, the Flattener replaces transparent objects with objects that are 
visually equivalent to the transparent originals, but contain no transparency. These new opaque 
objects are often referred to as flattened transparency. Flattened transparency does not contain 
any live transparent elements and, therefore, cannot be manipulated. If you think it may be 
necessary to make changes to the artwork after the flattening process has taken place, make sure 
to save a copy of the unflattened artwork for future editing.

The following common file types do not support live transparency (the Flattener must flatten 
transparent objects prior to printing or exporting): PostScript, EPS, DCS, PDF 1.3 and earlier, 
PDF/X, GIF, JPEG, BMP, and versions of TIFF that do not conform to the TIFF 6.0 specification 
(for example, TIFF files created with a version of Photoshop software prior to version 6.0).

PDF versions and transparency
When saving a file as PDF from an Adobe Creative 
Suite component, PDF 1.3 is listed as Acrobat 4; 
PDF 1.4 is listed as Acrobat 5; PDF 1.5 is listed as 
Acrobat 6; and PDF 1.6 is listed as Acrobat 7.

Because the PostScript language does not support 
live transparency, any PDF produced by Adobe 
Acrobat Distiller—even though it may be PDF 1.4 or 
1.5—will not contain live transparency. All trans-
parency is flattened in the process of PostScript 
generation. 

Editable transparency in Illustrator files
An EPS or PDF file created in Illustrator 9, 10, CS, or CS2 
may have been saved with the Preserve Illustrator Ed-
iting Capabilities option selected (in the EPS or Adobe 
PDF Format Options dialog box). In the case of EPS 
and PDF 1.3, the file will contain flattened transpar-
ency; however, you can access the native Illustrator 
data by opening the file in an appropriate version of 
Illustrator. Then you can edit the live transparency 
and resave it with the appropriate flattener settings. 

Source of transparency
An object that has a transparency effect applied to it 
is called a source of transparency.

Interacts with transparency
An object or placed file that appears under a source 
of transparency (regardless of the layer) interacts with 
transparency. 
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Determining if an object will be flattened
An object that has a transparency effect applied to it is called a source of transparency. An object 
or placed file that appears beneath a source of transparency (regardless of the layer it is on) inter-
acts with transparency. Objects that are a source of transparency or interact with transparency 
are processed by the Transparency Flattener, possibly resulting in changes to their composition 
in the output.

An object is a source of transparency if any of the following applies: 

• It has an opacity of less than 100%. 

• It has any blending mode other than Normal.

• It has an opacity mask (Illustrator).

• It has a drop shadow or feather.

• It has a inner glow or outer glow effect (Illustrator).

• Its fill or stroke has a style, brush, pattern, or filter effect that  
has any of the previous properties.

• It is a placed Photoshop file (native, PDF, or TIFF) with a transparent background.

• It is a placed Illustrator file (native or PDF) that contains one or more objects with any of the 
previous properties.

Flattener Preview palette
Use the Flattener Preview palette in Illustrator CS2, 
InDesign CS2, and Acrobat 7 Professional to highlight 
objects that are a source of transparency or that will 
be affected by the flattening process. (See “Using the 
Flattener Preview to detect transparency“ in the “Best 
Practices” chapter for more information.)

Flattener Preview and Simulate Overprint
In the Flattener Preview palette in Illustrator CS2, you 
can see which objects will be affected by flatten-
ing when you select the Simulate Overprint option. 
The Simulate Overprint option is not available in the 
Flattener Preview palette in other Adobe publishing 
applications. However, in Acrobat 7 Professional, over-
printing objects can be inspected with the Output 
Preview function.

Reader 7 includes Overprint Preview
Reader 7, unlike previous versions, includes Overprint 
Preview support, to display overprints contained in 
PDF files. Reader 7 users can now preview overprint-
ing objects in a PDF file.

�

�
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Illustrator CS2 Transparency Palette
A. Blending mode B. Opacity C. Opacity Mask

Glow effects (left to right): No glow, Inner glow, 
Outer glow (right)

In Illustrator, InDesign, or Acrobat 7 Professional, the best way to determine if an object inter-
acts with transparency is to use the Flattener Preview (discussed in the “Best Practices” chapter) 
and to choose the All Affected Objects preview option. Determining if an object interacts with 
transparency without using the Flattener Preview is not easy. However, in general, an object 
interacts with transparency if: 

• It is a source of transparency.

• It is overlapped by a source of transparency. 

• It is very close to (usually within one point) a source of transparency and beneath it in stacking 
order (including objects on other layers).

The Flattener and Simulate Overprint
When the Flattener flattens transparency, it may use overprinting commands in the resulting 
file to create transparent effects using opaque objects. The Flattener uses overprinting when flat-
tening transparency that interacts with a spot color. In order to correctly print or view a PDF file 
containing flattened transparency, it is necessary to use software (a RIP or previewing applica-
tion) that supports overprinting. Without overprinting support, flattened transparency may not 
print or display the desired effect. Objects that are set to overprint will, instead, knock-out the 
objects beneath them. The illustrations in this section show how a flattened drop shadow placed 
on top of a spot color appears in Acrobat 7 Professional with Overprint Preview turned on and 
Overprint Preview turned off.

When you choose the Simulate Overprint output option in various print and export dialog 
boxes in Illustrator, InDesign, and Acrobat 7 Professional, the Flattener creates the visual effect 
of overprinting. Choosing this option causes the Transparency Flattener to preprocess all of the 
overprint attributes and render them without reliance on overprinting. In this instance, there 
does not need to be any live transparency in the file for the Flattener to be invoked.
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Overprint Preview in Acrobat 7 Professional: In this example, the image prints in two colors—spot color blue 
and black. The image on the left, viewed with Overprint Preview off, shows that the Flattener uses overprinting 
in order to print a drop shadow on top of a spot color. The image on the right, viewed with Overprint Preview 
on, shows how the image appears on output devices that support overprinting.

If the flattened file will be viewed with software or printed to a printer that doesn’t support over-
printing, choose the Simulate Overprint option when creating the file. Simulate Overprint is use-
ful for creating proofs, but it is generally not advisable for final production output. With Simulate 
Overprint chosen, the Flattener converts spot colors to process in any affected area during the 
flattening process. While the conversion of spot colors to process may not be a problem during 
the proofing process, it is not desirable if spot colors are to be used in the printing process. The 
flattened graphic that follows has the same appearance as its spot color original, but because the 
Simulate Overprint option was chosen, it contains no spot colors—it will print in CMYK.

Simulate Overprint: In this example, the original image is two colors: spot color blue and black. However, 
since Simulate Overprint was used, the image has been converted to four process colors (CMYK). Although this 
image appears visually the same as the right image in the Overprint Preview graphic, this image prints very 
differently—rather than two colors, it will print in four color process (CMYK).

The flattening process explained
To achieve the visual effect of transparency with the use of opaque objects, the flattening tech-
nology examines the interactions at every point of the transparency and does several things to 
the objects involved:

• The Flattener cuts the original transparent objects apart and replaces overlapping transparent 
regions with a set of discrete, abutting objects called atomic regions. Each atomic region stands 
on its own and does not rely on underlying or overlapping objects for its final appearance.

The flattening process: Flattening cuts transparent objects apart to represent overlapping areas as discrete 
pieces that are either vector objects or rasterized areas. This example only involves vector objects. The diagram 
shows how live transparency (left) is split into flattened atomic regions (middle image is exploded view). The 
final output (right) simulates the original, but it uses opaque elements. As a design becomes more complex 
(mixing images, vectors, type, spot colors, overprinting, and so on), so does the flattening and its results.

• When using the built-in High Resolution Flattener Preset, the Flattener retains the integrity of 
original transparent objects whenever possible (for example, type remains type and vectors re-
main vectors). However, based on the complexity of a design and the flattener settings used, it 
may convert type or strokes to outlines or expand patterns. (See the “Controlling the Flattener” 
chapter for information about Flattener Presets.)

• If an object being processed by the Flattener has either its fill or stroke set to overprint, the 
Flattener may process the overprinting. If the Flattener processes overprinting, the flattened 
objects it creates will not have any overprinted fills or strokes. (See “Overprinting” in the 
“Controlling the Flattener” chapter.) 
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File types that may contain live transparency
To keep your workflow as flexible as possible, you should make sure that all flattening is done as 
close as possible to making the final output. Keeping transparency live until the end of the pro-
duction process allows you to make last minute production decisions without having to worry 
about the settings used for any previously flattened items. Familiarizing yourself with files that 
can contain live transparency allows you to make wise decisions when planning your production 
workflow.

The following file types allow you to keep transparency live until print time:

• .AI files from Illustrator 10, CS, and CS2

• PDF 1.4, 1.5, and 1.6 files created directly in Illustrator 9, 10, CS, or CS2; InDesign 2, CS, or 
CS2; or saved by Acrobat 5, 6, or 7 Professional. Note that virtually all PDF files created with 
Acrobat Distiller software will not contain live transparency.

• EPS from Illustrator 9, 10, CS, and CS2 (The file must have been saved with the Preserve 
Illustrator Editing Capabilities option chosen, and you must open the file in Illustrator.)

• PDF 1.3 from Illustrator 9, 10, CS, and CS2 (The file must have been saved with the Preserve 
Illustrator Editing Capabilities option chosen, and you must open the file in Illustrator.)

Flattening in Illustrator, InDesign, or Acrobat 7 Professional
It is often best to keep transparency live throughout as much of the production process as pos-
sible (up to, and including, flattening in the RIP). You can flatten any of the live transparency 
contained in the formats listed in the previous section by using Illustrator CS2, InDesign CS2, 
or Acrobat 7 Professional—either by directly opening the file or placing it as a graphic and then 
printing or exporting it. In addition, Illustrator CS2 lets you flatten individual objects when you 
are editing the file. To flatten and edit the file, select the objects you want to flatten, and then 
choose Object > Flatten Transparency. Once flattened, the transparency effects are no longer live 
and their appearance is not easily modified. (See “Object Flattener dialog box” in the “Flattening 
Controls in Illustrator CS2” chapter.)

The Illustrator CS2 Flatten Transparency dialog box allows you to preview and flatten: Using the object 
flattening control feature, (Object > Flatten Transparency), you can flatten individual objects prior to output and 
save the flattened version in the document. This dialog box has a Preview option (the check box on the right) 
that allows you to see exactly what will happen during the flattening process. This can be an excellent aid for 
determining exactly what the Flattener will do at various settings.
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Chapter 3: Controlling the Flattener
All Adobe publishing applications use similar Flattener technology, but the flattening controls in 
each application differ slightly. This chapter describes the settings used to control the Flattener as 
well as how to use them. For a more thorough discussion about Flattener settings, see the “Best 
Practices” chapter.

Transparency Flattener settings dialog boxes: The Transparency Flattener Preset Options dialog box from 
InDesign CS2 (top left) and Illustrator CS2 (bottom left). The transparency flattening settings in the Advanced 
Print Setup dialog box from Acrobat 7 Professional (right). Acrobat 7 Professional does not support Flattener 
Presets—you control the Flattener settings by using the same controls in the Print and applicable export 
dialog boxes.

Flattener controls
During processing, flattening subdivides a design into regions and examines each region for any 
transparent objects. For regions that contain transparency, the Flattener assesses if the objects 
involved can be kept in their original form (for example, vectors as vectors or type as type), if 
they can be converted to a related form (for example, type to outlines), or if the entire region 
must be rasterized because of its complexity.

Raster/Vector Balance setting
The Raster/Vector Balance setting determines how hard the Flattener works to keep objects in 
their vector form in the flattened output. This setting can also affect flattening performance. For 
complex documents, flattening in vector form requires more time and memory than rasterization.

The Raster/Vector Balance setting works as follows:

 Raster/Vector Balance settings (left to right): Left-most setting, Intermediate Setting, Right-most setting 

• At the left-most setting (0), labeled Raster, the Flattener rasterizes all of the objects on 
any page that includes at least one transparent object. Note that all objects on the page are 
rasterized, regardless of whether or not they contain or interact with transparency themselves.

• Intermediate settings (1-99) affect the degree to which the Flattener rasterizes (or doesn’t 
rasterize) areas of transparency as determined by the number of paths, the number of objects, 
the amount of object overlap, and the type of objects in that area. The design complexity of a 
document is the primary influence for what happens during flattening. In many simple uses of 
transparency, the results may be no different at any setting  zero (that is, no rasterization occurs).

• At the right-most setting (100), labeled Vector, the Flattener tries to keep all of the objects in 
their original, vector form. At the full vector (100) setting, the Flattener nearly always produces 
the best looking output. However, due to the complexity of keeping designs in vector form, 
this is the slowest of the Raster/Vector settings. As you create your workflows, start with this 
setting and move the slider towards Raster if time becomes an issue. Even at this setting, some 
amount of rasterization may be unavoidable. For example, the flattened objects required to 
represent a transparent vector shape filled with a gradient mesh may be rasterized, but the 
Flattener creates a clipping path to define their edges.



Transparency in Adobe Applications: 9 
A Print Production Guide

The best way to determine what the Flattener is going to do is to use the Flattener Preview func-
tion in Illustrator CS2, InDesign CS2, or Acrobat 7 Professional. Choose one of the preview op-
tions in the Flattener Preview palette to quickly determine the areas that will be affected by the 
flattening process. (See “Flattener settings and Flattener Preview” later in this chapter.)

For final high-resolution output, always select the highest Raster/Vector setting (vector) unless 
you want to reduce the time or memory required to flatten a particularly complex transparent 
design. However, be sure to lower the Raster/Vector no more than necessary to avoid an unac-
ceptable degree of rasterization.

Flattener resolution settings
The resolution settings control the resolution (in pixels per inch) that rasterized transparent 
areas receive during flattening. Two settings are common to all Adobe publishing software:

Resolution settings in the InDesign CS2 Transparency Flattener Preset Options dialog box: Use these 
settings to control how the Flattener rasterizes transparent objects that it is not reproducing in vector form. 
These settings are also available in Illustrator CS2 and Acrobat 7 Professional (see Chapters 6 and 8).

• Line Art and Text Resolution: This setting determines the resolution applied to vector art 
and text that need to be rasterized by the Flattener during the flattening process. Set the Line 
Art and Text Resolution setting at the minimum resolution needed to represent fine elements, 
such as small fonts or thin strokes, on your output device. Typically, on devices up to 600 dpi, 
just use the resolution of the device. For high resolution devices (such as imagesetters and 
platesetters), you may find that using precisely half of the device’s resolution rather than the 
full resolution is sufficient; using this lower resolution will decrease the flattening times and 
reduce file sizes as compared to using the full resolution. For example, when printing to a 2540 
dpi output device, using a 1270 ppi resolution for line art may produce acceptable results.

• Gradient and Mesh Resolution: This setting determines the resolution applied to any meshes 
and gradients that are involved in transparency. In addition, InDesign CS2 applies this resolu-
tion to all InDesign drop shadows and feathered edges. This setting controls the resolution of 
all meshes and gradients printed to RIPs that don’t support the PostScript 3 “Smooth Shading” 
feature. The Flattener will ignore this setting if mesh- or gradient-filled objects aren’t involved 
in transparency and are printed to a PostScript 3 RIP.

One setting is unique to Illustrator:

• Document Raster Effects Settings Resolution (Illustrator 10, CS, and CS2): This setting 
determines the resolution applied to all raster effects in Illustrator. These effects include drop 
shadows, vignettes, and feathered edges.

The Illustrator CS2 Document Raster Effects Settings dialog box: Use this dialog box (Effect > Document 
Raster Effects Settings) to control the way Illustrator CS2 rasterizes effects applied in the Effect menu.
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Flattener options
Flattener options provide important controls that may improve the final appearance of transpar-
ent objects after flattening. Flattener options include the following:

Conversion option settings in the InDesign CS2 Transparency Flattener Preset Options dialog box: 
Use these settings to control how the Flattener processes text, strokes, and whether it should clip complex 
regions of rasterized transparency with a clipping path. These settings are also available in Illustrator CS2 and 
Acrobat 7 Professional (see Chapters 6 and 8).

• Convert All Text to Outlines: This setting controls how type is processed, and causes the 
Flattener to convert all type to outlines (whether the type interacts with transparency or not). 
In some cases, this option eliminates flattening artifacts that are apparent on-screen and when 
printing to lower resolution output devices. For example, with this option turned off, some 
type may be converted to outlines, while other type remains unaffected. On low resolution out-
put devices, the outlined type may appear heavier than the unaffected type. With this setting 
enabled, all type will print with the same weight.

• Convert All Strokes to Outlines: This setting controls the processing of strokes and causes the 
Flattener to convert all strokes to outlines—whether they interact with transparency or not. In 
some cases, this option eliminates flattening artifacts that are apparent on-screen and when 
printed to lower resolution output devices.

• Clip Complex Regions: This setting controls the Flattener’s analysis of complexity regions 
(discussed later in this chapter). When selected, this option creates clipping paths around these 
portions of a transparent design. (See the “Clip Complex Regions” section of the “Best Prac-
tices” chapter.)

• Preserve Alpha Transparency (Object Flattening in Illustrator CS2): This setting is only ap-
plicable to explicit flattening in Illustrator by using the Object > Flatten Transparency option. 
The concept of alpha transparency only takes into account the attribute of opacity; it does not 
include blending modes. After you’ve flattened the transparency with this option chosen, alpha 
transparency remains and the resulting artwork is suited for Scalable Vector Graphics (SVG) 
and Macromedia Flash File Format (SWF) web file formats. All objects with blend modes other 
than Normal are flattened and their appearances are preserved. In general, do not use this set-
ting in the context of print workflows.

• Preserve Overprints and Spot Colors (Object Flattening in Illustrator CS2): This setting is 
only applicable to explicit flattening in Illustrator by using the Object > Flatten Transparency 
option. The Preserve Overprints and Spot Colors setting produces the same effect as using 
Preserve Overprints in the Advanced pane of the Print dialog box.

Transparency flattening settings unique to the Flatten Transparency dialog box in Illustrator CS2: 
These settings (Object > Flatten Transparency) are only available when flattening individual or groups of 
objects in Illustrator CS2. 
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Flattener presets
In InDesign CS2 and Illustrator CS2, you control the Flattener’s settings by using transparency 
flattener presets. You can use one of the three built-in presets or create your own custom presets. 
You can save, export, and distribute custom presets to other computers in your organization 
and, if necessary, to your customers. Presets make it easy to ensure consistent flattening results 
throughout the workflow. 

Creating flattener presets
The process of creating flattener presets in InDesign CS2 and Illustrator CS2 is the same. The 
following discussion focuses on InDesign; differences between InDesign CS2 and Illustrator CS2 
are indicated where necessary.

1 Choose Edit > Transparency Flattener Presets to access the Transparency Flattener Presets 
dialog box.

 

Transparency Flattener Presets dialog box from InDesign CS2: The buttons labeled Load and Save in 
this dialog box are labeled Export and Import, respectively in Illustrator CS. The buttons perform the same 
function in both applications.

 This dialog box provides access to defined Flattener presets. Use New and Edit to create and 
modify custom styles. From the Transparency Flattener Presets dialog box, you can load Flat-
tener presets created by others or save your own presets for distribution.

 Note that you cannot modify the predefined presets. You can, however, select a preset and click 
New to create a new preset based on the settings of the selected one.

2 Choose Edit > Transparency Flattener Presets > New to add custom Flattener presets. 

Adding a Transparency Flattener preset in InDesign CS2: The Transparency Flattener Preset dialog box lets 
you define and edit Flattener styles that you can use when printing or exporting.

 This dialog box provides access to the Raster/Vector Balance control, Flattener options, Line 
Art and Text setting, Gradient and Mesh Resolution setting, and it allows you to define custom 
Flattener presets. New styles use the settings of the currently selected style. 

 You can use Flattener presets when printing or exporting from InDesign CS2 and 
Illustrator CS2.
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3 Choose File > Print or File > Export, and then click Advanced in the Print or Export dialog 
box to use an existing Flattener preset.

Choosing a Transparency Flattener preset in the Export Adobe PDF dialog box of InDesign CS2: The 
Flattener preset option is available in both the Print and Export dialog boxes.

 You can apply a Flattener preset to a document by using the Print, Export, and in 
Illustrator CS2, Save As dialog boxes. A menu in the dialog boxes lets you select the 
desired preset.

 Note that in InDesign CS2, an option also lets you temporarily disable any Spread Flattening 
override options applied by means of the Pages palette. (See “Spread flattening overrides” in 
the “Flattening Controls in Adobe InDesign CS2” chapter.)

No Flattener presets in Acrobat 7 Professional
Acrobat 7 Professional does not use Flattener presets. The Flattener is controlled in the Print, 
Save As, or PDF Optimizer dialog box. When printing, adjust the Flattener settings by selecting 
File > Print, and then click the Advanced button. To edit the settings, choose Transparency Flat-
tening from the list on the left in the Advanced Print Setup dialog box.

When you save a file as PostScript or Encapsulated PostScript (EPS), adjust the Flattener settings 
by selecting File > Save As, select the desired file format, and then click the Settings button. To 
edit the settings, choose Transparency Flattening from the list on the left to edit the settings.

Flattener settings and Flattener Preview
The Flattener Preview option is your most important tool when working with files containing 
live transparency. Using the Flattener Preview in Illustrator CS2, InDesign CS2, and Acrobat 7 
Professional is the best way to determine exactly which elements in a file are going to be affected 
by flattening prior to generating the output. This section gives some examples of the effects of 
several Transparency Flattener settings on an artwork sample. Illustrator CS2 was used to create 
the artwork, but the effects would be the same in InDesign CS2 and Acrobat 7 Professional.

Control the Flattener Preview by using the Flattener Preview palette. To access the palette, 
choose Flattener Preview from the appropriate menu.

Accessing the Flattener Preview palette (left to right): This graphic shows menus from 
Acrobat 7 Professional, InDesign CS2, and Illustrator CS2.
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In the following graphic, the artwork being flattened consists of three overlapping elements, each 
with a blending mode of Multiply. Each element consists of a blend from an inner to an outer 
shape. In the example, the blend is from a star to a circle. The combinations of transparent blends 
creates a condition in which the Transparency Flattener may rasterize portions of the artwork, 
depending on the Raster/Vector Balance setting.

 

Flattening example image: The left image shows the artwork in Illustrator CS2 outline mode. The right image 
is the artwork in normal preview mode.

With the Raster/Vector Balance set to 0 (full raster), the only option available in the Highlight 
pop-up menu in the Flattener Preview palette is Rasterized Complex Regions (because every-
thing on the page is part of the complexity region). Note that all three objects are included in 
the rasterized region, and that the Clip Complex Regions option is not enabled. The edges of the 
three circular objects will be rendered at the Gradient and Mesh resolution.

Illustrator CS Flattener Preview palette: The Flattener Preview identifies and highlights which objects are 
sources of transparency or will be affected by flattening. In this example, the Raster/Vector slider is set to 0 (full 
raster), so all of the artwork will be rasterized.

With the Raster/Vector Balance set to 5, the Highlight pop-up menu offers additional options. At 
this setting, almost all of the artwork is still included in the rasterized region. Most (but not all) 
of the edges of the artwork will be rendered at the Gradient and Mesh resolution. Two portions 
of the outer edge of the bottom object are not included in the rasterized region, and would there-
fore be rendered as vectors. This Raster/Vector Balance setting could create a visible difference in 
the edges at the points where the raster and vector edges meet.

Flattener Preview palette: Highlight pop-up menu: When you choose Highlight > Rasterized Complex 
Regions, all elements that will be rasterized by the Flattener are highlighted. This graphic has the Raster/Vector 
set to 5, allowing some portions of the artwork to remain as vectors.If the Raster/Vector Balance is set to 5, and 
you choose the Clip Complex Regions option, the Flattener will create a clipping mask that renders the outer 
edges of the artwork with a clean, uniform vector edge.
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If the Raster/Vector Balance is set to 5, and you choose the Clip Complex Regions option, the 
Flattener will create a clipping mask that renders the outer edges of the artwork with a clean, 
uniform vector edge.

Flattener Preview palette: Clip Complex Regions: This graphic shows how Clip Complex Regions affects 
flattening.

With the Raster/Vector Balance set to 20, only the central portions of each object are rasterized. 
If you choose the Clip Complex Regions option, the Flattener will create a clipping path along 
the image’s contours. Note that in this case, portions of the internal circular edges will be 
rasterized. The places where these rasterized edges meet their vector neighbors may be visible.

Flattener Preview palette: Raster/Vector slider: This graphic shows the effect of moving the Raster/Vector 
slider toward vectors. In this case, the Raster/Vector slider is set to 20 and Clip Complex Regions is chosen, 
causing only some of the artwork to be rasterized..

With the Raster/Vector Balance set to 75 or higher, no portion of the artwork will be rasterized. 
As a result, the Rasterized Complex Regions option in the Highlight pop-up menu is disabled.

Flattener Preview palette: No rasterization will occur: In this graphic, the Raster/Vector slider is moved close 
enough to Vectors so that no items are rasterized.
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Getting the desired results
Achieving high-quality, flattened results depends largely on using the appropriate Flattener set-
tings for your production process and output device. Improper settings can contribute to poor 
quality or unexpected results. (Using an incorrect Flattener setting is analogous to saving a file 
in the wrong format or choosing the wrong color profile.) If you get unexpected results from the 
Flattener, you can usually correct the situation by adjusting the Flattener settings or changing 
the stacking order of transparent objects (or objects affected by transparency) in the original 
files. The remainder of this section describes some common issues you may encounter when 
working with the Flattener.

Visual effects of rasterization and outlining
Because the Flattener outlines or rasterizes type and vectors, it can sometimes produce undesir-
able visual results, such as color stitching, jaggies, or slightly thickened letterforms or strokes. 
These results can be more pronounced if the Flattener rasterizes or outlines only a portion of a 
complex design. The Flattener rasterizes or outlines objects based on: the kinds of objects being 
flattened (such as type, gradients, and spot colors), the file’s complexity, and the settings that are 
in effect when the flattening takes place.

For example, if the Flattener rasterizes or converts a portion of a line created with a stroke into 
a filled outline object, the line may slightly change width at the point where the conversion hap-
pens. These effects can occur when printing to a PostScript device because PostScript processes 
strokes differently than filled outline objects. If you get this effect in your output, try choosing 
the Convert All Strokes to Outlines option in the Flattener settings.

Output devices and resolutions
Sometimes rasterization is required as part of flattening. The resolution used for rasterization 
must be user defined because the output device resolution is not automatically available at the 
time of flattening. If the flattener resolution is too low, areas of rasterization may become appar-
ent and may not visually match adjoining unrasterized areas. If the Flattener resolution is set 
inappropriately high, flattening time may be long and output files may be large without a notice-
able improvement in quality.

As the following example shows, adjoining atomic regions can, under certain circumstances, 
cause thin white lines to appear. These lines are known as display artifacts. The noticeable white 
gap between the two portions of the background is typically a display-only artifact when viewing 
a flattened PDF in a viewer that does anti-aliasing or smoothing. (In Acrobat 7 Professional, the 
options that may cause stitching in the preview are called Smooth Linework, Smooth Text, and 
Smooth Images in the Page Display section in the Preferences dialog box.)

Artifacts: This graphic simulates the appearance of display artifacts (indicated by the arrows). The artifacts (thin 
white lines) only appear when viewing a flattened object on-screen—they will not appear in print output. 

Host and RIP font mismatch
In some situations, a font loaded on your computer is replaced by a similar font that is loaded 
on a printer’s RIP. For example, the font Helvetica™ is one of the standard fonts that is in-
cluded in all PostScript RIPs. In the PostScript printer description file (PPD) for a PostScript 
printer, Helvetica is listed as being resident in the printer. When you print a job in which you 
use Helvetica, the PostScript file generated by the application may not include the version of 
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Helvetica on your local system—the RIP’s version is used instead. If the version of a font in the 
RIP differs from the version used on your computer, the flattened text may look different than 
the text the RIP printed using its version of the font. When printing from InDesign 2, CS, or CS2 
you can avoid this issue by choosing Download PPD Fonts in the Graphics panel of the Print 
dialog box.

Color stitching and artifacts
Color stitching is the visible color transition that appears between objects whose coloring would 
otherwise be identical. It most commonly occurs when the Flattener rasterizes only a portion of 
a vector object.

Font conversion during flattening
If text is involved in transparency, the Flattener often needs to rasterize or outline some of the 
glyphs in the text. The Flattener uses the font information contained in the font files on the 
computer where the flattening is taking place. Because the Flattener only flattens text in areas 
affected by transparency, it’s possible that some glyphs will be flattened while others remain 
unaffected. In most instances, you cannot detect a difference between the flattened and normal 
text in the final output.

The example job, shown in the following graphic, demonstrates that the Flattener may need to 
outline type if the type is involved in transparency. Outlined type does not have font hinting ap-
plied, which can make the outlined type appear heavier than type which has not been outlined. 
Selecting the Convert All Text to Outlines flattener option ensures that all of the text is uniform 
in weight.

�

�

�

� �

Outlined text in Illustrator CS2: A. The results of flattening the design using the High Resolution Flattener 
preset. The text block on the left, which is under the star’s drop shadow, was outlined by the Flattener. The 
text block on the right remains unaffected. B. Simulates how the design might print on a low resolution output 
device. Notice how the outlined text appears heavier than the other text. C. The Illustrator CS2 Flattener Preview 
palette. At the top are the High Resolution flattening settings used. At the bottom are the Transparent Objects. 
D. The Illustrator CS2 Layers palette shows the stacking order for the objects used in this example. Note that if 
the text had been placed on top of the drop shadow, it would not have been outlined. Whenever possible, you 
should place text on top of a transparent element to prevent it from being outlined. E. The text block in the red 
area is outlined, the other text remains unaffected by transparency.

Font hinting
Hinting refers to instructions built into a font to opti-
mize its shape at a wide range of sizes.
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Overprinting
If a document contains no transparency, Illustrator CS2 and InDesign CS2 preserve overprint-
ing. If overprinting is mixed with transparency, the Flattener may remove the overprint settings, 
but it maintains the appearance of the overprinting in the flattened image.

If an overprinting object interacts with transparency, the Flattener will process the overprint 
(that is, the overprinted object is broken down into atomic regions and their colors take the 
overprint into account). Flattening of overprinting does not change the visual appearance of 
the graphic.

In other scenarios, the Flattener may generate overprint instructions as a result of the flatten-
ing—even if no overprint instructions were originally present. Overprint instructions can be 
created when the Flattener processes spot color objects that interact with transparency. For this 
reason, it is important that you enable overprinting support on the RIP.
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Flattening, overprinting, and spot colors: This image shows the effects of flattening on overprints and 
spot colors.

The following list contains conditions under which the Flattener preprocesses overprinting 
instructions. Note that when you save an Illustrator EPS file, these conditions still apply—even 
when Overprints is set to Preserve: 

• Overprinting objects have transparency directly applied to them (for example, they are less 
than 100% opaque).

• Overprinting objects are part of a group to which transparency is applied.

• Overprinting objects overlap (that is, sit underneath—regardless of layer) and are within ap-
proximately one point of objects or groups that are transparent.

• Overprinting objects are in a placed file to which you apply transparency. 

• Overprinting objects are part of a complexity region that the Flattener must rasterize.

In most cases, the results of preprocessing overprinting instructions by the Flattener is identical 
to what happens when a PostScript RIP interprets the same overprinting instructions.

Image replacement proxies (OPI/APR) and flattening
When the Flattener encounters a region of a document that involves images that interact with 
transparency (for example, transparent type or a drop shadow that falls over an image), it 
uses whatever image data is present during flattening to render the overall effect. If the image 
involved is a low-resolution placeholder or OPI proxy image, the Flattener uses that image. The 
PostScript (or flattened PDF) output does not contain the comments required by the OPI server 
to replace the low-resolution image with its high-resolution counterpart. In fact, the original im-
age was probably broken up among multiple atomic regions. Unless you are absolutely sure that 
an image does not interact with transparency, you must fatten (that is, replace the low-resolution 
images with high-resolution images) before you flatten transparency—“Fatten before you flatten!”

Transparency effects applied to placeholder or proxy images are properly rendered only if you 
perform image replacement prior to flattening. The impact on your workflow depends on the file 
formats that you use and the applications that are involved. If your workflow is based on Adobe 
PDF, and you use an OPI server that operates on PDF 1.4, you can keep transparency live by 
using PDF 1.4 until after performing image replacement. If the workflow is based on PostScript 
or EPS, you must manually perform image replacement from within Illustrator or InDesign 
prior to flattening.
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Chapter 4: Transparency and Color
It’s important to properly configure the color settings in InDesign CS2 and Illustrator CS2 prior 
to flattening a job. Colors involved in transparency may be transformed by the Flattener during 
the flattening process—if the application’s color settings are not configured correctly, the colors 
affected by the Flattener may not match the actual press conditions.

Whether or not you use a color-managed workflow, you need to be aware of how transparency 
in your jobs can affect your color output. In this chapter you will learn how the Transparency 
Flattener can affect your existing color workflows and how to configure the Flattener’s settings to 
achieve optimal color output.

Transparency Blend Space
In order to blend transparent objects together, the Flattener must use a single color space (RGB 
or CMYK) in which to perform the blending. This space is referred to as the Transparency Blend 
Space (or simply, “blend space”), and may be either the RGB or CMYK document color space. In 
InDesign CS2 and Illustrator CS2, the document color space is set in the Working Spaces section 
of the Color Settings dialog box (Edit > Color Settings). For example, if the Transparency Blend 
Space is set to CMYK, the color space profile used is the one defined as the document’s CMYK 
Working Space. If a document is not being color-managed, a generic RGB or CMYK color profile 
is assigned to the document color space. 

The Transparency Blend Space setting is determined differently in InDesign CS2, Illustrator CS2, 
and Acrobat 7:

In InDesign CS2, a document may contain both RGB and CMYK color objects so you must 
choose whether to use the RGB or CMYK blending space (Edit > Transparency Blend Space).

In Illustrator CS2, the blending space of a document is always the same as the document color 
mode (File > Document Color Mode) because Illustrator CS2 documents must be constructed in 
either an RGB or CMYK color mode.

In Acrobat 7 Professional, a PDF document may contain both RGB and CMYK color objects. 
When printing, Acrobat 7 Professional uses the Color Profile setting from the Output section of 
the Advanced Print Setup dialog box. Ideally, when printing to a CMYK output device this color 
profile will be the same color space in which CMYK objects in the PDF already reside. Using the 
same color space will prevent CMYK-to-CMYK conversions during flattening.

Get to this Color Profile settings by doing the following: 

1 Choose File > Print.

2 Click the Advanced button to get to the Advanced Print Setup dialog box.

3 Select Output from the list on the left.

Choosing the appropriate Transparency Blend Space in InDesign CS2
In InDesign CS2, the Transparency Blend Space setting is application based, rather than docu-
ment based, like Illustrator CS2.

The Transparency Blend Space menu item: Choose this menu item to set the transparency blending space for 
the document.

Color management and Adobe Creative Suite
The topic of color management is beyond the scope 
of this document. For information about color 
management in Adobe Creative Suite 2, see, “Color 
Workflows for Adobe Creative Suite 2.”

Color terminology: color model and color space
A color model is the dimensional coordinate system 
used to numerically describe colors. Some models 
include RGB, HSB, CMYK, and L*a*b*. The transparency 
blending space allows you to choose between CMYK 
and RGB color models.

Color space is a variant of a color model and has a 
specific gamut (range) of colors. For example, within 
the RGB color model are a number of color spaces: 
Adobe RGB, sRGB, and Apple RGB. While each of these 
color spaces defines color using the same three axes 
(R, G, and B), their gamuts are different.

http://www.adobe.com/products/creativesuite/pdfs/cs2_color_workflows.pdf
http://www.adobe.com/products/creativesuite/pdfs/cs2_color_workflows.pdf
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Use this list to determine the appropriate setting.

If you create documents for print only, choose Document CMYK for the blend space.

If you create documents for web only, choose Document RGB for the blend space.

If you create documents for both print and web, decide which is most important, and then 
choose the blend space that matches the final output.

If you create a high-resolution print piece that you’ll also publish as a high-profile PDF 
document on a web site, you may need to switch the blending space back and forth before final 
output. In this case, be sure to reproof the color on every spread that has transparency. Avoid 
using the Difference and Exclusion blend modes—these modes can change the appearance 
dramatically.

Transparency Blend Space and color management
The color conversions that the Flattener performs are in addition to the conversions performed 
at output. When a job that contains live transparency is printed (or exported to a file format that 
doesn’t support live transparency) there are two steps in the process where color conversions may 
occur: the Transparency Flattener and the print engine of the application; further color conver-
sions may happen in the printer.

Printing transparency: step-by-step
When printing a page containing live transparency from InDesign CS2 and the Transparency 
Blend Space is set to Document CMYK, the following steps will take place (steps 3 and 6 may 
perform color conversions):

1 Transparency is detected on a spread by the Flattener.

2 The Flattener refers to the Transparency Blend Space setting to determine the appropriate 
color space in which to blend transparent objects. In this example, Document CMYK was 
selected. The Document CMYK color space is determined by the active color settings (Edit > 
Color Settings).

3 Any image that is tagged with a color space that differs from the selected blend space is con-
verted to Document CMYK.

4 The Flattener flattens the transparency.

5 The flattened data is passed to the print engine.

6 The print engine compares the color information in the flattened data with the Printer Profile 
color space set in the Print dialog box. If the color settings don’t match, the print engine con-
verts the colors to the color space indicated by the Printer Profile.

7 The color-managed job is printed.

Example 1: No color conversion
Scenario: You have an InDesign document that contains a single spread. On the spread, there is 
one CMYK image and one element that contains transparency. The CMYK image contains a pro-
file that matches both the InDesign document’s CMYK Working Space profile and the Printer 
Profile. The Transparency Blend Space setting is set to Document CMYK.

Using the step numbers from the previous “Printing transparency: step-by-step” section: 

3 Since the image’s color profile matches the profile of the transparency blending space, no con-
version is necessary during the flattening process.

6 Because the image’s color profile also matches the Printer Profile, no color conversion is neces-
sary place by the print engine.

In this example, no color conversions take place. 

Placing EPS files into Illustrator CS2
When placing an EPS file into Illustrator CS2, you can  
link or embed the file. If you choose to embed the file, 
it is converted to the document color mode during 
the embedding process. If you link the file, it main-
tains its color settings until the Illustrator document is 
printed or exported. 
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Example 2: Unwanted color conversion due to incorrect Transparency Blending Space setting
Scenario: You have an InDesign document that contains a single spread. On the spread, there is 
one CMYK image and one element that contains transparency. The CMYK image contains a pro-
file that matches both the InDesign document’s CMYK Working Space profile and the Printer 
Profile. Unlike Example 1, the Transparency Blending Space is set (incorrectly for this job) to 
Document RGB.

Using the step numbers from the previous “Printing transparency: step-by-step” section:

3 Since the image’s color profile does not match the profile of the transparency blending space, 
the image is converted from the CMYK color space to the Document RGB space.

6 The image’s color space has been converted to Document RGB by the Flattener and therefore 
does not match the CMYK printing space. At this point, the print engine converts the image 
back to CMYK.

In this example, two unnecessary color conversions took place due to the improper setting of 
the Transparency Blend Space. These unwanted color conversions would very likely result in an 
noticeable shift in the color of the image. 

Color-managed images and the Flattener
When preparing color-managed images (tagged with an ICC profile) for use in an InDesign or 
Illustrator CS2 job that contains transparency, keep in mind the following: if the image uses a 
color space that does not match the Transparency Blend Space, and that image is placed on a 
page or spread that contains transparency, the image will be converted to the color space of the 
transparency blend space—regardless of whether or not the placed image is involved in trans-
parency. Converting the colors of all objects on a spread to the color space of the Transparency 
Blend Space results in consistent color across any two same-colored objects on a spread, and 
prevents visible color shifts at the edges of transparency.

Untagged images and the Flattener
When Illustrator CS2 or InDesign CS2 encounter untagged (not color-managed) images that use 
a color model that is the same as the blend space’s color model, the application assumes those im-
ages are saved in the same color space as the blend space. Therefore no color-management related 
conversions will occur.

Settings for color-managed images
When placing images into InDesign CS2 and Illustrator CS2, it’s always best to use images that 
have been prepared for the same color space as the Transparency Blend Space. This way when 
flattening occurs, no color conversion is necessary.

Settings for images to be used in both CMYK and RGB workflows
When creating an image that is to be used in both RGB and CMYK workflows (such as for print 
and web), it is best to save the image as a color-managed RGB file. Only a small change in image 
appearance occurs in the conversion from one RGB color space to another RGB color space, or 
an RGB color space to a CMYK color space.

Avoid CMYK-to-CMYK conversions
Do not place a color-managed CMYK image that is saved in a color space that differs from the 
Transparency Blend Space, especially if the blend space is CMYK. CMYK-to-CMYK conver-
sions often result in a noticeable change in image appearance due to the nature of the conversion. 
CMYK-to-RGB conversions are somewhat better in this respect, but also not desired.

In-RIP color management and transparency
If you want to use your RIP’s color management features, you may have to make changes to the 
way you work. This is necessary because of the way the Transparency Flattener works—if there 
is a transparent item on the same page (or spread, in the case of InDesign CS2), the Flattener has 
to convert all graphics and images to the Transparency Blend Space. The color transformation 
for graphics on these pages are handled by the Flattener before the RIP gets the data. If you want 
to use your RIP’s color management function for jobs that contain transparency, you have two 
options: letting RIP partially color-manage your job or work in a large color space.
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Letting RIP partially color-manage your job
While the Flattener performs color conversions on pages that contain transparency, it does not 
make any conversions on pages that don’t have transparency. In this scenario, you let the Flat-
tener convert the colors for graphics on pages with transparency, and you let the RIP convert the 
colors on pages without transparency. 

To use this method, your document working space in Illustrator CS2 or InDesign CS2 should be 
the same as the output device’s color space. This ensures that the Flattener and the RIP converts 
all elements to the same color space.

Work in a large color space
Some digital output devices are capable of print colors that are not available in a standard press 
CMYK gamut (for example, by using more than four ink colors). In some cases, RIPs for these 
devices have built-in color management that optimizes the colors of the graphics for the device’s 
gamut. To take advantage of the RIP’s color optimization, you can work in a large color space 
(such as Adobe RGB) in your Adobe Creative Suite 2 application.

This method works well if you have control over the creation of the images and graphics that 
you print. If you control how the graphics are created, make sure they are created in a large color 
space (for example, Adobe RGB). After placing the Adobe RGB images into your Adobe Creative 
Suite 2 application, make sure your blend space is set to Document RGB, and that your RGB 
working space is Adobe RGB. Since your graphics’ color profiles match that of the working space, 
no color transformation takes place—even on pages with transparency. 

Spot colors in exported Illustrator files
In Illustrator 10, CS, or CS2 artwork, you can only obtain correct spot color separations of a file 
that contains transparency if the file is exported in specific formats:

• Native Illustrator 10, CS, or CS2 (in which transparency remains live)

• Illustrator 10, CS, or CS2 EPS (in which transparency has been flattened)

• PDF 1.4, 1.5, or 1.6 (in which transparency remains live)

In the case of other flattened formats, such as EPS files that were created by using Illustrator 
version 9 or earlier and PDF 1.3 and earlier, spot colors may convert to process when you save the 
file and transparency will be lost.

The Flattener and spot colors
The use of spot colors with transparency is fully supported in Adobe Creative Suite 2 applica-
tions. For most jobs, no special treatment is needed for spot colors; however, there are a few 
special circumstances in a print workflow where spot colors may be converted to process: the use 
of certain blending modes, converting spot colors of placed graphics to process, and the use of 
the Simulate Overprint feature. 

Blending modes that affect spot colors
Certain blending modes, such as Difference, Exclusion, Saturation, and Luminosity, can intro-
duce unexpected process colors or convert spot colors to process. If these blending modes are 
used in your files, create a flattened PDF file and use the Separation Preview feature in Acrobat 7 
Professional to determine what colors will print.

Converting placed graphics that contain spot colors and live transparency to process
If you place a graphic (such as a native Illustrator file that contains spot colors and live transpar-
ency into InDesign CS2) and then use InDesign to covert the spot color to process when printing 
or exporting, there may be color discrepancies between the spot color in the placed graphic and 
InDesign created elements that use the same spot color. This difference is caused by the way the 
Flattener processes live transparency in placed graphics compared with processing live transpar-
ency in the format of the application in which the Flattener is running.
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Illustrator CS2 process conversion warning dialog box: If your Illustrator document contains a spot color and 
transparency, this dialog box appears.

Simulate Overprint
The Simulate Overprint feature (see the “The Flattener and Simulate Overprint” section in the 
“Flattening Basics” chapter) converts all spot colors in a document to process colors, whether or 
not they are involved in transparency. This feature is primarily intended for creating proofs on 
color printers that don’t support overprinting; use of this feature is generally not recommended 
for final production output.

Preview separations
Be sure to use the Separations Preview available in InDesign CS2 and Output Preview in 
Acrobat 7 Professional to confirm your expectations prior to output.

  

Previewing separations: These palettes allow you to turn on and off the display of individual separations, and 
also display the color values at the position of your mouse on the page. The Output Preview palette in Acrobat 7 
Professional is shown on the left. The Separations Preview palette from InDesign CS2 is on the right.
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Chapter 5: Best Practices
As a service provider, you often receive files from Adobe publishing software without knowing 
exactly what they contain. To properly process these files, you need to determine if they contain 
any live transparency. In addition, you need to properly configure the settings that the Flattener 
uses before it flattens a file.

This chapter discusses strategies for detecting live transparency by using the Flattener preview 
and how to use the Flattener’s settings to determine the elements that flattening effects.

Stacking order
Wherever possible place text and line art elements above all nearby sources of transparency to 
minimize the possibility that the Flattener will process them. If the artwork allows, place such 
elements on their own layer that is above all layers containing sources of transparency. The fol-
lowing graphics demonstrate how the stacking order can affect Flattening. (These screenshots are 
from Illustrator CS2, however, the same results would be produced if the artwork were flattened 
in InDesign CS2 or Acrobat 7 Professional.) 

� �

�

Unwanted outlined type during flattening: These examples show text on a layer underneath a drop shadow 
(an object containing transparency). A. Since the word Lorem is beneath a transparent object, it will be affected 
by the Flattener. B. After flattening, the characters are converted from font glyphs to outlines. C. When printed 
to a low resolution output device, Lorem may appear bolder than Ipsum because it has been converted to 
outlines.

� �

�

Text placed above transparency prevents outlining: In this example, the text is positioned above the drop 
shadow. A. The Flattener Preview palette shows that the text will not be affected by the Flattener (the text is not 
colored red). B. Text before flattening. C. The “after flattening” results confirm that none of the font glyphs were 
converted to outlines.

Stacking order within a layer
Stacking order is the front-to-back or top-to-bottom 
order of objects on a page, both within and between 
layers. The stacking order of an object within a 
layer can be set by using the Bring to Front, Bring 
Forward, Send Backwards, and Send to Back options 
in the Object > Arrange menu in InDesign CS2 and 
Illustrator CS2. 
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Overprint support
In some cases, when spot colors are involved in transparency, the Flattener relies on overprinting 
to render the proper result. Be sure your PDF viewers, composite proofers, and production RIPs 
implement overprinting and that they are not set to ignore it. When viewing a PDF file that con-
tains flattened transparency in Acrobat 7 Professional, Reader 7, or InDesign CS2 (the PDF file 
would need to be placed into an InDesign CS2 document), enable Overprint Preview to properly 
view the flattened transparency. 

Using the Flattener Preview to detect transparency
As mentioned previously, the Flattener preview, available in InDesign CS2, Illustrator CS2, 
and Acrobat 7 Professional, is the best way to detect transparency in a file that was created with 
Adobe publishing software.

The following table contains the various Flattener preview options and functions. Not all options 
are available in each application, so the table indicates the application in which you can find 
each option.

F L AT T E N E R  P R E V I E W  F U N C T I O N S  BY  A P P L I C AT I O N

I N D E S I G N  C S 2 I L L U S T R AT O R  C S 2 AC R O B AT  7  
P R O F E S S I O N A L F L AT T E N E R  P R E V I E W  F U N C T I O N

• • • Affected Graphics shows all placed graphics that are involved in transparency.

• Affected Linked EPS Files shows all placed-linked EPS files that are involved in transparency.

• • • All Affected Objects shows all objects that interact with transparency.

• •

All Rasterized Regions shows all regions of the document that the Flattener would rasterize. These regions 
include complexity regions (previewed by the Rasterized Complex Regions preview option) as well as rasterized 
atomic regions. (To use this option in Illustrator, you must select Detailed Preview in the Flattener Preview 
palette menu.)

• • Expanded Patterns shows all patterns that would be expanded because they are involved in transparency.

• • • Outlined Strokes shows all strokes that would convert to outlines because they are involved in transparency or 
because you selected Convert All Strokes to Outlines.

• • Outlined Text shows all text that would be converted to outlines because it is involved in transparency or 
because you chose the Convert All Text to Outlines option.

• Raster-fill Text and Strokes shows all text and strokes that the Flattener will outline to act as clipping masks 
for rasterized image data.

• • • Rasterized Complex Regions shows areas that will be rasterized as determined by the Raster/Vector Balance 
control.

• • •

Transparent Objects shows objects that are sources of transparency, including those objects to which 
non-normal blending modes, styles, and raster effects are applied, as defined in the “Determining if an object 
will be flattened” section in the “Flattening Basics” chapter. This option also highlights overprinting objects that 
interact with transparency.

Flattening and printing performance trade-offs
Generally (when using resolution settings appropriate for high quality printing), if the Ras-
ter/Vector Balance in your Flattener setting is set to Vector (the far right position), the time and 
memory required to flatten a file may be greater if the file contains extensive transparency. The 
resulting flattened file, however, is usually smaller and takes less time for spooling because its 
rasterization is kept to a minimum. If the Raster/Vector Balance is set to Raster (the far left posi-
tion), the time and memory required to flatten the same file can be substantially less. The result-
ing flattened file, however, may be much larger and take more time for spooling.

In either case, a flattened file may take longer to print than a file that doesn’t require flattening 
because of the memory demands a flattened file places on the RIP. These demands occur 
either because the Raster/Vector Balance setting has created an excessively large rasterized file 
or because the Raster/Vector Balance setting has created a file filled with a large number of small 
vector objects and clipping paths. (See “Choosing the proper resolution settings” later in this 
chapter.)

Creating a customized high-resolution flattener 
preset
You may want to make your own variation of the 
high-resolution Flattener preset. For example, if your 
device has an output resolution of 2540 ppi, you 
might create a preset with a Line Art and Text resolu-
tion of 1270 or 2540 ppi.
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Flattener option settings and when to use them
The Flattener in Illustrator CS2, InDesign CS2, and Acrobat 7 Professional includes the follow-
ing options:

Convert All Text to Outlines With this option, all type converts to outlines, whether it inter-
acts with transparency or not. If you do not choose this option, type converts to outlines only as 
necessary in transparent regions.

Because the Flattener may be required to convert type involved in transparency to outlines, con-
verted text can appear thicker or bolder on-screen and when printed to lower-resolution output 
devices. Furthermore, stitching problems may occur when only a portion of the text is converted 
to outlines. You can often avoid this problem by converting all type to outlines.

 
 

(left to right) Original, Convert All Text to Outlines turned off, Convert All Text to Outlines turned on:
In some cases you cannot move text above a transparent object because the text needs to be affected by the 
transparency. In this example, the red text must be affected by the transparent box and drop shadow, so it 
cannot be moved above the transparent object. By converting all text to outlines, the text not being flattened 
appears the same as the text being flattened. The screenshots were taken from Illustrator CS2 after using the 
Flatten Transparency feature (Object > Flatten Transparency).

Some side effects of choosing this option are that by converting all type to outlines you may 
degrade its appearance (it may appear bolder than normal), and you may increase flattening 
time or memory requirements. You may, therefore, want to manually convert text to outlines in 
Illustrator CS2 or InDesign CS2 where type interacts with transparency.

Convert All Strokes to Outlines With this option, all strokes convert to outlines whether 
or not they interact with transparency. If you do not choose this option, the Flattener converts 
strokes to outlines only as necessary in transparent regions. This option is very similar to the 
Convert All Text to Outlines option mentioned before, except instead of applying to type, it ap-
plies to strokes.

Because the Flattener may be required to convert strokes involved in transparency to outlines, 
converted strokes can appear thicker and less precise on-screen and when printed to lower-reso-
lution output devices. Stitching problems may occur when the Flattener only converts a portion 
of a stroke to outlines. Avoid this problem by converting all strokes to outlines; doing so will 
prevent the Flattener from converting only a portion of a stroke into an outlined element.

Some side effects of choosing this option are that by converting all strokes to outlines you may 
degrade their appearance (they may appear thicker than they should), and you may increase flat-
tening time or memory requirements. You may, therefore, want to manually convert strokes to 
outlines where they interact with transparency.

Clip Complex Regions With this option, the Flattener creates clipping paths around complex-
ity regions—certain rasterized portions of a transparent design. This option is only available if 
the Raster/Vector Balance is set at an intermediate position between the left and right settings.

If you set the Raster/Vector Balance setting to any intermediate value, Clip Complex Regions 
decreases the possibility of stitching problems along the boundaries of the complexity region. It 
may also eliminate white backgrounds and stitching artifacts within the flattened file.
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A side effect of choosing this option is that the resulting clipping path may be so complex that 
older RIPs without sufficient RAM may be unable to print the resulting file.

 

Choosing whether to clip: The left close-up clearly shows the adverse effects of not clipping complex regions 
when flattening. Much of the shape’s edge has been rasterized, creating an obvious visual difference where 
the rasterized regions meet the portions of the objects that remain in vector form (the upper right part of the 
shape is vectors). The right close-up shows the beneficial effect of choosing Clip Complex Regions in flattening 
these objects. 

Choosing a file format
When making decisions about the file types to use in your production workflow, try to choose a 
format that supports live transparency. (The file formats that support live transparency are listed 
in “Types of transparency” in the “Flattening Basics” chapter.) Using a file format that supports 
live transparency is the best choice for prepress because you have complete control over the flat-
tening process until the moment the file is printed or output.

Illustrator native, InDesign native, and PDF file formats
Because they can contain live transparency, Illustrator CS2 native, InDesign CS2 native, and 
PDF 1.4, 1.5, or 1.6 file formats are the best choice for prepress. 

Photoshop files
Photoshop files with transparent backgrounds correctly print and output when you place them 
into Illustrator or InDesign documents. Most applications that can accept file formats with 
transparency masks (such as TIFF and PDF 1.4 and 1.5) can use this transparency information.

Note that Illustrator CS2 and InDesign CS2 let you directly place native Photoshop files; how-
ever, all visible layers are effectively flattened—any remaining transparency is reduced to a single 
alpha channel. As a result, the blending modes of layers in a Photoshop file (.PSD) do not remain 
live when placed into one of these applications.

File formats that do not support live transparency
If you must use a file format that doesn’t support live transparency (for example, PostScript, EPS, 
PDF 1.3, or PDF/X), consider the following:

• Illustrator artwork that you save as Illustrator 10, CS, or CS2, EPS, or PDF 1.3 is flat-
tened—allowing you to place the file in older layout applications—but it may be opened in an 
unflattened state in Illustrator at any time to inspect and correct flattening problems (should 
they occur). You can open the file in an unflattened state because these formats contain all of 
the live transparency information in an Illustrator specific section of the file. You can open 
these files in Illustrator CS2, restore the live transparency objects for editing, and resave it with 
new flattener settings.

• InDesign CS2 files saved as either EPS or PDF 1.3 are flattened, but they correctly retain over-
printing and spot colors.
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Choosing the proper resolution settings
Before flattening, adjust the Flattener resolution settings to match your target output conditions 
for the following file types that contain live transparency:

• Native Illustrator 10, CS, and CS2 (.AI)

• PDF 1.4, 1.5, or 1.6 files created directly from Illustrator 9, 10, CS, or CS2; InDesign 2, CS, 
or CS2; and files saved by Acrobat 5, 6, or 7 Professional. Note that any PDF file created with 
Acrobat Distiller will not contain live transparency (because Distiller processes PostScript to 
create a PDF and PostScript cannot contain live transparency).

• EPS from Illustrator 9, 10, CS, and CS2 (the file must have been saved with the Preserve 
Illustrator Editing Capabilities option chosen, and it must be opened in Illustrator).

• PDF 1.3 from Illustrator 9, 10, CS, and CS2 (the file must have been saved with the Preserve 
Illustrator Editing Capabilities option chosen, and it must be opened in Illustrator).

Basic guidelines for setting Flattener resolutions
Although your workflow requirements may vary, the following general guidelines will help you 
choose the proper resolution settings for your files:

Transparency Flattener Preset Options: The Transparency Flattener Preset Options dialog box from 
InDesign CS2.

The Line Art and Text Resolution should be based on the resolution of the output device. 
To achieve the highest quality output, set the Line Art and Text Resolution to be equal to the 
output device resolution. In many cases, you can reduce the size of the output file and flattening 
time—without a significant reduction in quality—by setting this resolution to exactly one-half 
of the resolution of the output device. InDesign CS2, for example, uses a value of 1200 dpi for 
its built-in high resolution flattener preset. This resolution is appropriate for use with an output 
device that has a resolution of 2400 dpi. The Flattener also uses this value as the upper limit for 
rasterizing atomic regions in all transparency-savvy applications.

The Gradient and Mesh Resolution should match what is commonly used for drop shadows 
created in Photoshop (for example, 300 ppi). InDesign CS2 uses this value when it flattens drop 
shadows and feather effects applied to page objects. The Flattener also uses this value as the lower 
limit for rasterizing atomic regions in all transparency-savvy applications.

Note that this is the same value that applications already use for rasterizing meshes and gradients 
when printing documents to RIPs that don’t support the PostScript 3 smooth shading feature.

The Document Raster Effects Resolution (Illustrator only) should match what is commonly 
used for drop shadows created in Photoshop (for example, 300 ppi). This value applies to all ras-
ter effects used in Illustrator, including live raster effects and resolution-dependent filters, such 
as Gaussian Blur.

Rasterization and resolution settings
Previous pages of this guide discuss flattening and rasterization in broad terms. The following 
section discusses rasterization in greater detail.

The following is a list of situations in which the Flattener may rasterize vector elements:

Flattening atomic regions Flattening divides the transparency of a document into a collection 
of discrete areas called atomic regions. If an atomic region contains an image or multiple trans-
parent gradient or mesh objects, the region is rasterized. The Flattener applies the Gradient and 
Mesh Resolution to this region unless it contains one or more images, in which case it applies 
the maximum of their resolutions. The Flattener also clips the resulting raster with the affected 
region’s outline, thus preserving its shape in a resolution-independent form.
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Flattening complexity regions A complexity region is an area that isn’t retained in vector 
form except at the highest Raster/Vector Balance setting. Complexity regions are typically made 
up of a large number of objects that interact with transparency. Flattening a complexity region 
involves rasterizing all vector objects, images, and text inside it at the Line Art and Text Resolu-
tion. For this reason, make sure to set the Line Art and Text Resolution to a value that closely 
matches the characteristics of the output device.

Rasterization of type The Flattener will rasterize type at the Line Art and Text Resolution set-
ting instead of converting it to outlines if you use a bitmapped or protected font. 

Illustrator CS2 pixel-based raster effects Pixel-based raster effects in Illustrator CS2, such as 
Gaussian Blur, are rasterized with the Document Raster Effects Resolution before flattening and, 
therefore, the Flattener treats them as regular images.

Rasterization of overprinted objects When overprinted objects are rasterized, the appearance 
of overprinting is maintained in the final output.

Rasterizing atomic regions containing gradients or image data
The Flattener uses the Gradient and Mesh Resolution when rasterizing an atomic region unless 
the atomic region contains images. If the atomic region contains images, the resolution at which 
it is rasterized is that of the highest-resolution image involved. 

Here are some examples to clarify these relationships:

• If a region to be rasterized includes a gradient mesh object and the Gradient and Mesh Resolu-
tion is set to 150 ppi, the region is rasterized at 150 ppi.

• If a region to be rasterized includes image data at 250 ppi and 300 ppi, the 250 ppi image will 
be upsampled to 300 ppi (using a bi-linear sampling algorithm), and the region is rasterized at 
300 ppi.

When the Flattener processes an area that includes a placed image, it attempts to leave both the 
image resolution and any user-applied rotation unprocessed. The Flattener may not be able pre-
serve the rotation or resolution of a rasterized image if several images, gradients, or meshes are 
intersecting in an atomic region. The Flattener uses an algorithm which allows it to automatically 
determine the rotation and resolution best suited for the atomic region. Generally, the Flattener 
does not downsample an image’s resolution in order to maximize the image quality. Should the 
Flattener need to process an image, it usually upsamples an image’s resolution. When processing 
images, the Flattener uses a bi-linear resampling algorithm.
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Chapter 6: Flattening Controls in Illustrator CS2
This chapter provides a high-level overview of the relevant transparency controls and features in 
Illustrator CS2. This chapter describes all of the menus, dialog boxes, preferences, and palettes 
that let you interact with the transparency features of Adobe Illustrator CS2. For more informa-
tion about Illustrator CS2 and its features, consult the Illustrator online documentation.

Transparency Flattener Presets dialog box (Edit > Transparency Flattener Presets)
To access the Transparency Flattener Presets dialog box, choose Edit > Transparency Flattener 
Presets. This dialog box provides access to defined Flattener presets. Use New and Edit to create 
and modify custom styles. From the Flattener Presets dialog box, you can also import Flattener 
presets created by customers or export your own presets for distribution. The presets you create 
here will be available when you print or save a file to a format that needs to be flattened.

You cannot modify the predefined presets. You can, however, select one, and then click New to 
create a new preset using the currently selected preset as a starting point.

The Transparency Flattener Presets and Transparency Flattener Preset Options dialog boxes in 
Illustrator CS2: Use the Transparency Flattener Presets dialog box (Edit > Transparency Flattener Presets), 
shown at left, to create and modify existing presets. The three presets shown are not editable, but if you select 
one of the presets in the list and click New, you can create a new preset, shown at right, using the selected 
preset as a starting point.

Document Setup dialog box (File > Document Setup)
To access the Raster/Vector Balance control, the Flattener options, the Line Art and Text Resolu-
tion, and the Gradient and Mesh Resolution options, choose File > Document Setup, and then 
select the Transparency panel. You may select one of the built-in Flattener presets for the current 
document or click the Custom button to create your own ad hoc setting. The Flattener uses the 
settings in this dialog box when exporting a file or copying objects to the Clipboard.

Transparency panel in the Document Setup dialog box in Illustrator CS2: Use this dialog box 
(File > Document Setup) to set the flattening settings used by the Flattener when objects are exported or 
copied to the Clipboard.

Document Raster Effects Settings dialog box (Effect > Document Raster Effects Settings)
To access the Document Raster Effects Settings dialog box, choose Effect > Document Raster 
Effects Settings. Illustrator CS2 uses the Document Raster Effects Settings whenever you apply a 
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raster-based effect (for example, drop shadow and feather) to an object. Note that this behavior 
is different in InDesign CS2 and Acrobat 7 Professional, which use the Gradient and Meshes 
Resolution setting instead.

The Raster Effects Settings dialog box in Illustrator CS: Illustrator CS applies the resolution value in the 
Raster Effects Settings dialog box (Effect > Document Raster Effects Settings) to all rasterized effects in the file. 

You can verify this setting in the Graphics pane of the Print dialog box prior to printing the file.

Flattener Preview palette (Window > Flattener Preview)
To access the Flattener Preview palette, choose Window > Flattener Preview. This feature, also 
available in InDesign CS2 and Acrobat 7 Professional, is the best method to find the areas of a 
document that the Flattener will process. (For more information about Flattener settings, see the 
“Best Practices” chapter.)

The Flattener Preview palette in Illustrator CS2: Use the Flattener Preview palette (Window > Flattener 
Preview) to determine which objects will be affected by the Flattener.

Object Flattener dialog box (Object > Flatten Transparency)
To access the Object Flattener dialog box, select the items you want to flatten, and then choose 
Object > Flatten Transparency. This feature lets you flatten individual objects while you edit the 
file. However, to keep files that contain transparency as device independent as possible, it’s best 
to keep transparency live until just prior to printing—so flattening in this way is discouraged. 
This feature is not available in InDesign CS2 or Acrobat 7 Professional.

The Flatten Transparency dialog box in Illustrator CS2: Use the Flatten Transparency dialog box to flatten 
individual elements.
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If you need to apply object flattening to objects in an Illustrator file, it’s important to note that 
there are two options available in the Object Flattener’s Flatten Transparency dialog box that are 
not available in the Flattener Preset Settings dialog box:

• Preserve Alpha Transparency

• Preserve Overprints and Spot Colors

Keep in mind that these settings are unique to the Object Flattener’s Flatten Transparency dialog 
box in Illustrator CS2.

Print dialog box (File > Print)
The Transparency Flattener settings in the Print dialog box are located in its Advanced panel. To 
access the Advanced panel:

1 Choose File > Print.

2 Click the Advanced item in the list on the left of the Print dialog box.

3 In the Overprint and Transparency Flattener Options section, choose a Flattener preset (or 
create a temporary Flattener setting).

 

The Print dialog box in Illustrator CS2: In the Advanced section of the Print dialog box (File > Print) choose 
the Flattener preset to be used during the printing process.

Save As dialog box (File > Save As)
To access the Save As dialog box, choose File > Save As. Select a file format, and then click Save. 
If the format you are saving to requires flattening, use the Transparency section in this dialog 
box to select a Flattener preset (or create a temporary Flattener setting), and then choose how 
you would like overprints processed during the saving process. The location of the Transparency 
Flattening settings in the Save As dialog box depends on the file format that you are saving to. 
The settings can be in the Options dialog box or in an Advanced section of the dialog box.

The Save As dialog box in Illustrator CS2: Use the Transparency section of this dialog box (File > Save As) 
when saving to a file format that doesn’t support live transparency.
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Chapter 7: Flattening Controls in InDesign CS2
This chapter provides a high-level overview of the relevant transparency controls and features 
in InDesign CS2. This chapter describes all of the menus, dialog boxes, preferences, and palettes 
that let you interact with the transparency features of InDesign CS2. For more information about 
InDesign CS2 and it features, consult the InDesign online documentation.

Transparency Flattener Presets dialog box (Edit > Transparency Flattener Presets)
To access the Transparency Flattener Presets dialog box, choose Edit > Transparency Flattener 
Presets. This dialog box provides access to defined Flattener presets. Use New and Edit to create 
and modify custom styles. From the Flattener Presets dialog box, you can also import Flattener 
presets created by customers or export your own presets. The presets you create will be available 
when you print or save a file to a format that needs to be flattened.

 

The Transparency Flattener Presets and Transparency Flattener Preset Options dialog boxes in 
InDesign CS2: Use the Transparency Flattener Presets dialog box (Edit > Transparency Flattener Presets) (left) to 
create and modify existing presets. The three presets shown are not editable, but if you select one of the presets 
in the list and click New, you can create a new preset (right) using the selected preset as a starting point.

PDF 1.3 Export (File > Export)
Because the PDF 1.3 format doesn’t support live transparency, your file may need to be flattened. 
To choose the Flattener preset to be used during the export process:

1 Choose File > Export. 

2 For Save as Type (Windows) or Format (Mac OS), choose Adobe PDF. Type a filename, choose 
a location for the file, and click Save to go to the Export Adobe PDF dialog box.

 When the Export Adobe PDF dialog box appears, it displays the General panel (you can select 
the General panel in the list on the left of the Export Adobe PDF dialog box).

3 In the Options section, set the Compatibility to Acrobat 4 (PDF 1.3). 

4 Select Advanced in the list on the left of the PDF Export dialog box to go to the Advanced 
panel.

5 In the Transparency Flattener section of the Advanced panel, select the Flattener preset you 
want to use.

 If this section is grayed out, make sure that you have chosen the Acrobat 4 (PDF 1.3) setting in 
the General panel. The PDF 1.4, 1.5, and 1.6 formats support live transparency, so no flattening 
occurs when exporting to these formats.
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The Export Adobe PDF dialog box in InDesign CS2: Use the Transparency Flattener section of the Export 
Adobe PDF dialog box to choose the Flattener preset that is used when exporting to versions of PDF that don’t 
support live transparency.

EPS Export (File > Export)
Because the EPS format doesn’t support live transparency, your file may need to be flattened. 
To choose the Flattener preset to be used during the export process:

1 Choose File > Export. 

2 For Save as Type (Windows) or Format (Mac OS), choose EPS. Type a filename, choose a loca-
tion for the file, and click Save to go to the Export EPS dialog box.

 The Export EPS dialog box appears and displays the General panel (you can select the General 
panel at the top of the Export EPS dialog box).

3 Click the Advanced tab at the top of dialog box to go to the Advanced Settings panel.

4 In the Transparency Flattener section, select the Flattener Preset you want to use.

The Export EPS dialog box in InDesign CS2: Use the Transparency Flattener section of the Export EPS dialog 
box to choose the Flattener preset that is used when exporting pages to EPS.

SVG and SVG Compressed Export (File > Export)
Because the SVG format doesn’t support live transparency, your file may need to be flattened. 
To choose the Flattener preset to be used during the export process:

1 If desired, select an object to export. (You do not need to select anything to export a page or 
spread.)

2 Choose File > Export.

3 Specify a location and a filename. Be sure to include the .SVG extension.

4 For Save as Type (Windows) or Format (Mac OS), choose SVG or SVG Compressed, and click 
Save. The SVG Options dialog box appears.

5 If necessary, click the More Options button to access the Transparency Flattener section, and 
then select the Flattener Preset you want to use.
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The Export SVG dialog box in InDesign CS2: Use the Transparency Flattener section of the Export SVG dialog 
box to choose the Flattener preset that is used when exporting pages to SVG.

Print dialog box (File > Print)
The Transparency Flattener settings are located in the Advanced panel of the Print dialog box. 
To access the Advanced panel:

1 Choose File > Print.

2 Click the Advanced item in the list on the left of the Print dialog box.

3 Choose a Flattener preset in the Transparency Flattener section.

The Advanced panel of the Print dialog box in InDesign CS2: Use the Transparency Flattener section of 
the Advanced panel in the Print dialog box to choose the Flattener preset that is used when printing your 
InDesign documents.

Flattener Preview palette (Window > Output Preview > Flattener Preview)
To access the Flattener Preview palette, choose Window > Output Preview > Flattener Preview. 
This feature, also available in Illustrator CS2 and Acrobat 7 Professional, is the best way to find 
areas of a document that the Flattener will process. (For more information about Flattener set-
tings, see “Best Practices”.)

The Flattener Preview palette in InDesign CS2: Use the Flattener Preview to determine the objects in the 
document that will be affected by the Flattener.
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Detecting transparency on a spread in InDesign CS2
In addition to the Flattener Preview, you can detect pages that contain transparent items by look-
ing at the Pages palette. Any page icon displayed with a checkerboard pattern indicates that its 
spread contains one or more transparent items. Use the Flattener Preview option to determine 
which items on the spread contain transparency.

Spread containing transparency in InDesign CS2: If a page or spread icon in the InDesign Pages palette has a 
checkerboard pattern, then at least one object on the page or spread uses transparency.

Spread flattening overrides (Pages Palette Menu > Spread Flattening)
You can apply a custom Flattener setting to specific spreads of an InDesign CS2 document. 
To access this setting, open the Pages palette, and then select Spread Flattening from the 
Palette’s menu.

You may want to flatten one or more spreads in a document using a different style than the one 
used for the rest of the document. This allows you to reduce flattening time and memory require-
ments without affecting the quality of other spreads. For example, if a placed Illustrator graphic 
contains a very complex piece of transparent artwork, you may want to flatten it with a different 
Raster/Vector Balance setting than the remainder of the pages in the document.

Applying a custom spread flattening setting in InDesign CS2: The InDesign CS Pages palette lets you apply 
a spread flattening override to a spread. You create a spread flattening override by means of the Pages palette 
menu. Select the spread, and then choose Spread Flattening from the Pages palette menu.

Applying a spread flattening override
The option for applying, or subsequently removing, a custom spread flattening setting is located 
in the Pages palette menu. This menu provides the following transparency related options:

• Default: Use the document flattening preset for this spread.

• None (Ignore Transparency): Ignore transparency for the spread.

• Custom: Open the Custom Spread Flattener Settings dialog box to specify the Flattener set-
tings you want used for the spread.

Disabling spread flattening overrides when printing or exporting
When you print or export a document, you can temporarily disable any flattening overrides by 
deselecting the Ignore Spread Overrides option on the Advanced panel of the Print and Export 
dialog boxes.
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Chapter 8: Flattening Controls in Acrobat 7 Professional
This chapter provides a high-level overview of the transparency controls and features in 
Acrobat 7 Professional. Acrobat 7 Professional supports PDF formats (PDF 1.4, 1.5, and 1.6) that 
contain live transparency created by exporting the file from Illustrator 9, 10, CS, and CS2, and 
InDesign 2, CS, and CS2. This chapter lists and briefly describes all of the menus, dialog boxes, 
preferences, and palettes that let you interact with the transparency features of Acrobat 7 Profes-
sional. For more information about Acrobat 7 Professional and its features, consult the Acrobat 
online documentation.

Flattener Preview palette (Tools > Print Production > Transparency Flattening)
To access the Flattener Preview palette, choose Tools > Print Production > Transparency Flat-
tening. You can also access the Flattener Preview palette by clicking the Transparency Flattening 
icon on the Print Production toolbar. Flattener Preview, also available in Illustrator CS2 and 
InDesign CS2, is the best way to find areas of a document that the Flattener will process. (For 
information about using Flattener Preview, see the “Flattener Settings and Flattener Preview” in 
the “Controlling the Flattener” chapter.)

The Flattener Preview palette in Acrobat 7 Professional: Use the Flattener Preview palette to view the 
objects that will be affected by the Flattener. You can also use this palette to apply flattening to individual pages 
of a PDF file.

Using the controls in the Apply to PDF section of the Flattener Preview palette, you can flatten 
your entire document or individual pages. Unlike when you print or export, which only flattens 
the data being sent to the output device or file, performing flattening in the Flattener Preview 
flattens the contents of the PDF file itself. This feature can be used to see how a particular Flat-
tener setting affects the color separations of a document.

To see how flattening affects your color separations:

1 To prevent accidentally overwriting your original file, create and open a copy of your PDF file.

2 Flatten the desired pages after configuring the controls in the Flattener Settings section of the 
Flattener Preview palette.

3 Once flattened, open the Output Preview palette (Advanced > Output Preview) and view the 
separation plates to ensure that the desired results were achieved. Note that if the PDF file con-
tained spot colors, and those spot colors were converted to process by the Flattener, the spot 
color names may be listed in the Output Preview panel’s color list (even though the spot color 
is no longer being used in the file). To get a list of colors currently being used, save, close, and 
then reopen the document.
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Print dialog box (File > Print)
The Transparency Flattener settings in the Print dialog box are located in its Advanced dialog 
box. To access the Advanced dialog box:

1 Choose File > Print.

2 Click the Advanced button.

3 Select Transparency Flattening from the list on the left of the dialog box, and configure the 
Flattener settings.

4 Because Acrobat 7 Professional does not use Flattener presets, you may want to save your set-
tings for future use by using the Save As button at the top of the Advanced dialog box.

The Advanced dialog box in Acrobat 7 Professional: Use this dialog box to configure the Flattener settings 
when printing PDF files that contain live transparency.

Save as PostScript or Encapsulated PostScript (File > Save As)
Because the PostScript programming language (this includes EPS) doesn’t support live transpar-
ency, your file needs to be flattened if it contains transparency. To choose the Flattener preset 
that the Flattener will use during the export process:

1 Choose File > Save As. 

2 For Save as Type (Windows) or Format (Mac OS), choose Encapsulated PostScript.

3 Click the Settings button to go to the Save As Settings dialog box. 

4 In the Save As Settings dialog box, choose Transparency Flattening from the list on the left and 
configure the Flattener settings.

5 Once you have configured the Flattener and any other settings, click OK to return to the Save 
As dialog box.

6 Once back in the Save As dialog box, set the filename and location of where the file is to be 
saved and click OK.

 

The Save As and Save As Settings dialog boxes in Acrobat 7 Professional: Acrobat 7 Professional allows you 
to save a PDF file in a number of formats. Select File > Save As and choose the desired format from the Format 
menu in the Save As dialog box. These screenshots show the dialogs for saving the PDF in EPS format. The Save 
As dialog box (left) is configured to save in Encapsulated PostScript format. The Save As Settings dialog box 
(right) is displayed when the Settings button is clicked in the Save As dialog box.
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Preserve Overprint option when printing or saving
In the Transparency Flattening section of the Print dialog box there is a Flattener Setting called 
Preserve Overprint. This setting is similar to the Simulate Overprint setting in the Print dialog 
box of InDesign CS2, and the Overprints setting in the Print dialog box of Illustrator CS2.

Unlike the Simulate Overprint setting in InDesign CS2, which applies to all pages whether or not 
there is transparency, the Preserve Overprint setting in Acrobat 7 Professional applies only to 
objects on pages that contain transparency and only to those objects that do not directly interact 
with the transparency on the page.

With the Preserve Overprint option selected, the Flattener behaves as follows:

• With the Preserve Overprint option selected, objects that have been set to overprint maintain 
their overprint attribute. In addition, if the object contains spot colors, the spot colors are 
preserved.

• With the Preserve Overprint option deselected, objects that have been set to overprint are 
processed by the Flattener. The objects lose their overprint attribute, but maintain the visual 
appearance of overprint. If an object contains spot colors, it is converted to process.
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Chapter 9: Troubleshooting
This section describes what you can to do to minimize or prevent problems in standard print 
production workflows. Each problem has corresponding descriptions and solutions. 

Tips
• Install and use the latest Adobe software updates. 

(www.adobe.com/support/downloads/main.html)

• Install and use the latest RIP software updates.

• Install and use the latest PPDs/printer drivers.

• Dedicate sufficient RAM to all applications.

• Visit the Adobe Print Resource Center. The Print Resource Center provides easy access to the 
latest tools and documentation from Adobe. 
(http://studio.adobe.com/us/print/main.jsp)

• Read the ReadMe.pdf files that accompany the installers for additional known issues, resolved 
issues, and production and troubleshooting tips.

• Ask your customers to provide you with information about the transparency they used in a 
job. Additionally, if your customers must do their own flattening, provide them with appropri-
ate Flattener presets for your output conditions.

• Pay attention to the stacking order of objects. Place, wherever possible, text and line art ele-
ments above all nearby sources of transparency to minimize the possibility that the Flattener 
will process them. You can minimize this possibility by placing such elements on their own 
layer above all layers containing sources of transparency.

Transparency-related issues
Some transparency interactions currently have no workarounds for optimal printing. Future ver-
sions of Adobe applications will likely address some of these interactions. Until then, however, be 
alert for the following elements when they are mixed with transparency:

Preseparated content (Photoshop DCS files) InDesign CS2 can extract high-resolution 
plate data from placed Photoshop DCS files, which can be flattened and output. This capability 
requires that the DCS files not contain any vector data other than a clipping path. DCS files from 
other applications should not be involved in transparency interactions. Illustrator CS2, does not 
support transparency interactions with any DCS file, regardless of the application that created it.

Duotone, tritone, or quadtone images place-linked into legacy Illustrator files While 
Illustrator CS2 handles these files properly, earlier versions of Illustrator do not.

Low resolution OPI images Replace all low-resolution images that will be flattened with high-
resolution versions. Remember, “fatten before you flatten.”

Planning for transparency
The degree to which the effects of flattening affect your work often depends on if the flattened 
results are appropriate for the next step of your workflow.

For instance, you cannot change type that gets converted to outlines with a PDF touch-up tool. If 
a file is to be immediately color separated for printed output, and the Flattener was correctly set, 
this issue is unlikely to occur. At other points in the workflow, however, it may cause a problem. 
Similarly, you may not be able to map one spot color to another color after flattening, but if the 
next workflow step is trapping, you may not need to map colors.

The goal of quality print output is to maximize the value of transparency and minimize the ef-
fects of the transformation to a flattened file.

http://www.adobe.com/support/downloads/main.html
http://studio.adobe.com/us/print/main.jsp


Transparency in Adobe Applications: 40 
A Print Production Guide

Treat flattening like preseparated content
You may want to think about workflows involving flattened art in the same way as those that 
involve preseparated content. With preseparated files, you can make corrections only by going 
back to a composite format. You cannot convert a spot color to process, fix a trap, change image 
resolution, or replace an image after the separations are made. Similarly, flattening binds artwork 
into a representation that precludes making certain changes unless you return to the original 
version.

For similar reasons, you should use file formats that preserve transparency without flatten-
ing—or those file formats that can be reflattened—whenever possible. These file formats include 
the following:

• Illustrator 10, CS, and CS2 native (transparency preserved)

• Illustrator 10, CS, and CS2 EPS (transparency can be reflattened in Illustrator 10, CS, and CS2)

• InDesign 2, CS, and CS2 native (transparency preserved)

• PDF 1.4, 1.5, and 1.6 from Illustrator and InDesign (transparency preserved)

Known issues
You are unlikely to encounter significant problems if you follow the recommendations in this 
guide. However, if a file requires special attention, you may find a solution here.

Issue: White lines appear when object flattening is performed on spot color gradients.

Relevant product
Illustrator

Description
If you have a spot color defined as a start or stop color of a gradient, flattening the gradient by us-
ing Object > Flatten Transparency command with the Raster/Vector Balance slider set to 0 (full 
raster) causes the appearance of thin white lines.

Solution
This issue has been fixed in Adobe RIPs that use versions of CPSI newer than 3011.106. When us-
ing earlier versions of the RIP, avoid using the Object Flattener, and flatten objects only by using 
the printing, Save as EPS, or Save as PDF 1.3 output options. Another workaround is to set the 
Raster/Vector slider to a value other than 0 (all raster).

Issue: White lines appear in the preview of object flattened images that have been 
rotated or sheared.

Relevant product
Illustrator

Description
If placed (linked or embedded) transparent images are rotated or sheared, white dotted lines may 
appear if you flattened the image using the Object > Flatten Transparency command. The lines 
are more noticeable with Overprint Preview turned on. The lines do not appear when you zoom 
in at percentages greater than 300%. Also, the problem does not occur when the Print/PDF/EPS 
Flattener is used.

Solution
This is a preview problem and does not occur when you print the image. Try flattening with Pre-
serve Alpha Transparency turned on. Also, try flattening the image with a Raster/Vector Balance 
setting greater than 20.
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Issue: The DSC comment “%%DocumentProcessColors:” found in PostScript and EPS 
files that Illustrator generates always specifies that content will appear on all four pro-
cess plates when a file is flattened with the Raster/Vector Balance slider set to 0.

Relevant product
Illustrator

Description
When the Flattener flattens a file using a Raster/Vector Balance setting of 0 (all raster) and that 
file contains a transparent object that uses less than all process colors, the resulting PostScript or 
EPS file’s “%%DocumentProcessColors:” DSC comment will always indicate that all of the pro-
cess colors are used. If you save that file as an EPS and place it into an application, the application 
will consider that all process colors are used in the EPS file. This may cause blank plates to print.

Solution
Set the Raster/Vector Balance setting to one that doesn’t cause objects to be rasterized. It may 
also be possible to avoid this issue by using the command Object > Flatten Transparency to flat-
ten individual objects prior to saving as an EPS.

Issue: The Flattener preview is not always correct.

Relevant product
Illustrator

Description
The Flattener preview may not correctly show some text that gets converted to outlines or some 
areas that get rasterized.

Some native objects may be expanded upstream or downstream of the Flattener preview, and 
the Flattener has no way of detecting these native images. For example, Illustrator type with a 
certain style applied gets outlined before being sent to the Flattener.

Solution
There is no workaround. This is a preview issue only. It is not a problem that causes improper 
printed output. It only relates to previewing rasterized artwork, outlined text, or expanded pat-
terns that occur ahead of the flattening process.

Note that the following commands, effects, or applied graphic styles in Illustrator can rasterize 
artwork, expand patterns, or outline text: Rasterize effect, Crystallize effect, Pointillize effect, 
Transmogrifier graphic style, Dropped Sherbet Type graphic style, and text objects modified 
with the Envelope Distort command.

Issue: Live transparency in an exported PDF 1.5 file appears solid when processed by 
Brisque 4.1.

Relevant products
InDesign CS and Creo Brisque 4.1

Description
When you process a PDF 1.5 file that contains live transparency on a Brisque 4.1, the appearance 
of the transparency is not maintained and the image appears solid.

Solution
Export the file as PDF 1.4. The Brisque 4.1 can flatten a PDF 1.4 file and maintain the transparent 
appearance.
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Issue: Users of Adobe certified RIPs that use PDF2PS converter version 3015.101 or 
3015.102 may encounter failures with placed Illustrator transparency.

Relevant products
Illustrator, InDesign, Creo Brisque 5 and PS/M 8, and older versions of Heidelberg Meta Dimen-
sions and Delta.

Solution
Output PostScript to avoid the use of this specific version of the RIP’s PDF2PS converter. Error 
does not occur with RIPs that use version 3015.103 of the PDF2PS converter.

Issue: Spot channels in raster images preview in black when processing flattened PDF 
1.3 on Brisque 4.0 and 4.1.

Relevant products
InDesign and Creo Brisque 4.0 and 4.1

Description
This issue includes .DCS, .PSD, and TIFF images included in the PDF 1.3 file. This is a preview 
issue only. The spot channel does remain as a spot plate (as long as the spots are set to be main-
tained on output). If the spot is used anywhere else on the page, or if there is no transparency on 
the page, it will preview correctly. PDF files that are generated by Distiller will preview with the 
same results. Note, this issue does not apply to Brisque 5.x.

Solution
Possible workarounds include:

• Export the file as PDF 1.4.

• Add an element on the page that uses that same spot color as the raster image.

• Use the Creo utility PDF2PS before sending to Brisque.

• Print as composite.

• Edit the preview color of the spot plate after it has been RIPped by the Creo application 
PressTouch.

Issue: Text in oblique (not italic) fonts in a PDF 1.4 with live transparency, which is pro-
cessed by the Prinergy 2.1.x transparency flattener, is skewed at the wrong angle.

Relevant products
InDesign and Creo Prinergy 2.1.x

Description
Oblique fonts have oblique angles that are achieved in the RIP as a transformation of the non-
oblique character outlines. The In-RIP Flattener in Prinergy 2.1.x may incorrectly process the 
transformation instruction that creates the oblique angle of glyphs. The incorrect angles will be 
particularly noticeable if the Flattener processes certain glyphs but not adjacent ones. Another 
noticeable instance is when the glyphs have strokes applied that will be rendered as outlines and 
do not match the fill that is rendered as a font. This issue does not apply to Prinergy 2.2 or later.

Solution
Flatten in InDesign by creating a PDF 1.3 for submission to the Prinergy system, or convert all 
oblique text to outlines in InDesign prior to generating the PDF 1.4.
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Issue: White stitching line appears in CMYK separations when a file with a spot color and 
transparency is processed at high resolution on the Heidelberg Delta v8 RIP.

Relevant product
InDesign CS2, Heidelberg Delta RIP version 8.

Description
InDesign CS2 files that contain spot-colored native artwork which interacts with one or more 
process colors and transparency may result in white stitching lines when saved to PostScript and 
processed by Heidelberg Delta version 8. Affected PostScript files include those saved using the 
In-RIP Separations or on host Separations settings in the Output pane of the Print Dialog box. 
Exporting PDF 1.3 from InDesign, opening the resulting PDF in Acrobat 6 or 7, and then saving 
to PostScript (Separations/In-RIP Separations) also causes this problem when processed by the 
Delta.

Solution
No known workaround.

Issue: When exporting to flattened PDF from InDesign CS2, a pixel shift will occur in 
rasters intersecting transparency where half of a raster image is down-sampled and the 
other is not.

Relevant product
InDesign CS2

Description
When exporting to PDF 1.3 from InDesign, raster images interacting with transparency will 
shift by one pixel if part of the image is down-sampled and part is not. Affected sources of rasters 
interacting with transparency on the page in InDesign include placed EPS, TIFF, and PDF files.

Solution
Turn off downsampling in InDesign’s PDF export settings; Alter the downsampling destination 
resolution in the PDF export settings to match that of the flattener’s; Alter the flattener resolution 
(adjust the flattener preset) to match that of the PDF downsampling destination resolution; Print 
to PostScript and Distill.

Issue: White seams appear on RIP output when placed raster images that have spot 
channels involved (Photoshop files) in transparency are exported to PDF 1.3.

Relevant product
InDesign

Description
White seams and gaps appear on the output where the spot channel meets the CMYK channels 
in some spots. The white seams and gaps are a single device pixel wide and are not visible when 
you open the PDF in Acrobat. This behavior does not occur when printing PostScript, and it does 
not occur if the image is not involved in transparency.

Solution
The best solution is to generate a PostScript file and create the PDF file by using Acrobat Distiller. 
You can manually trap the spot channel content in the image by using the Grow function in 
Photoshop. In some cases, but not all, turning off compression and downsampling eliminates 
the problem.
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Issue: Transparent gradients that mark only two process plates appear on the wrong 
plates when you export to PDF 1.4 and RIP with Adobe Configurable PostScript Inter-
preter (Adobe CPSI) versions 3015.102 or 3016.101.

Relevant products
InDesign and Adobe CPSI RIP versions 3015.102 or 3016.101 

Description
Colors in a gradient composed of only two process colors with transparency applied may mark 
the wrong plates when you export to PDF 1.4 and RIP on a device that uses the Adobe CPSI RIP 
versions 3015.102 and 3016.101. This problem does not occur in version 3016.102.

Solution
Contact your OEM and see if a new version of the RIP is available.

Issue: Stitching can occur when printing placed EPS or PDF files that contain spot 
colors and the spot color definition of a placed graphic differs from the definition in 
the host document.

Relevant product
InDesign

Description
If transparency interacts with the image, stitching can occur when printing a placed EPS or PDF 
file that contains a spot color with the same name but a different color definition as a swatch in 
the InDesign file.

The portion that is not involved in transparency uses the placed graphic’s spot color definition. 
The portion that is involved in transparency uses the document’s spot color definition. This issue 
only occurs with composite PostScript.

Solution
Make sure the spot color definitions in the placed graphics and the document match if you use a 
composite workflow.

Issue: Exported PDF with OpenType® fonts involved in transparency fails to RIP with 
Adobe CPSI 3011.106.

Relevant products
InDesign, Adobe CPSI 3011.106

Description
This issue is specific to RIPs using Adobe CPSI version 3011.106. Check with your RIP vendor to 
see if an update is available.

Solution
If possible, change the layering order of the objects so that the text is on the topmost level. To 
change the layering order, select the text box, and choose Arrange > Bring to front.
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Issue: In some cases, thin black or white lines appear where flattened objects abut when 
processed on the Creo Brisque.

Relevant products
InDesign and Creo Brisque

Description
This issue occurs when a large, radial-gradient filled rectangle is used for the page background 
and transparent text objects with drop shadows are placed on top of it.

Solution
With files that contain transparent text on top of images or vignettes, or text on top of transpar-
ent images, Creo does not recommend that you save files in Adobe applications with the Create 
Outlines option chosen because hairlines sometimes appear around the transparent text after 
you RIP the file. 

If, however, you select the Create Outlines option, you can prevent hairlines from appearing by 
RIPping the file at 600 dpi and specifying whole number values for CT and LW (for example, LW 
2400 and CT 600 [or 400]).

Issue: PDF 1.5 file exported from InDesign and processed on Agfa Apogee Series 2 fails 
to print.

Relevant products
InDesign and Agfa Apogee Series 2

Solution
Print to PostScript or export the document as a PDF 1.3 or 1.4 file, and then process at the RIP. 
This issue has been resolved in Agfa Apogee X.

Issue: Brisque is unable to recognize live transparency in PDF 1.5.

Relevant products
InDesign and Creo Brisque

Description
When processing a PDF 1.5 file containing live (unflattened) transparency, the transparent areas 
appear solid.

Solution
Export the file as PDF 1.4 to have the Brisque flatten the transparency. Print to PostScript or 
export as PDF 1.3 to control the flattening yourself.

Issue: Black lines appear over text with a drop shadow when flattened using medium 
flattener style.

Relevant products
InDesign, Heidelberg Delta 7.5, and Meta Dimensions 3.0 RIP

Description
Black lines may appear over text with a drop shadow when flattened using medium resolution 
flattener style when processing the file on Heidelberg Delta 7.5 or Meta Dimensions 3.0 RIP.

Solution
Use the high-resolution flattener style.
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Issue: Image-to-image traps cause unexpected results on flattened output when you 
process files on Rampage RIP.

Relevant products
InDesign and Rampage RIP

Description
When you apply a drop shadow to knockout text, the Flattener rasterizes the text (thus convert-
ing it into an image) and the Rampage RIP applies its image-to-image trapping rule to the text. 
When the RIP traps the text, it is choked and becomes skinny.

Solution
The solution requires that image-to-image trapping be disabled. Set Auto-trap Contone to Spread 
or Knockout. The Knockout setting disables trapping to contones. If the design will let you, 
bringing the text to the front may help to resolve the issue.

Issue: When you omit low-resolution OPI images from an unflattened PDF file Prinergy 
does not properly process the PDF file’s OPI comments.

Relevant products
InDesign and Creo Prinergy

Description
Even though the OPI comments are written correctly in the unflattened PDF file, Prinergy flat-
tens the file before it processes the OPI comments.

Solution

Do not use an “Omit for OPI” workflow for images involved with transparency (do not choose 
any of the Omit for OPI options when exporting PDF from InDesign). In other words, make sure 
that the low-resolution images are included in the file.
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Glossary

A
Atomic regions are the smallest intersections of one or more objects involved in transparency, or 
zones, into which the Transparency Flattener divides the page being flattened. Individual vector, 
text, or image objects may be divided among several atomic regions.

Automatic Picture Replacement (APR) is the Creo (Scitex) mechanism for using low-resolu-
tion proxy images in a page layout application that are then replaced with their high-resolution 
counterparts at the RIP. Do not use APR proxy images if they interact with transparency, or the 
proxy image will be processed into the final output by the Transparency Flattener, preventing 
high-resolution substitution at the RIP. See Open Prepress Interface (OPI).

B
Blend is an Illustrator feature that lets you create a series of intermediate objects and colors 
among two or more selected objects.

Blending mode is a specification for the ways that the colors of objects blend with the colors of 
underlying objects. Specifying any blending mode other than Normal (or applying opacity to 
the Normal blending mode) for an object causes it to be considered a source of transparency and 
requires it to be processed by the Transparency Flattener.

Transparency Blend Space is used when blending the colors of transparent objects. The colors of 
the transparent objects are converted to a common color space using either the CMYK or RGB 
color profile for the document. This blending space enables objects of multiple color spaces to 
blend when interacting transparently.

C
Clip is to use a vector object as a mask or window for other objects. Any portions of the clipped 
objects that lie outside the clipping object will be hidden. Because the clipping shape is a vector 
object, its edge will be rendered at the resolution of the output device.

Clip Complex Regions is a Transparency Flattener option that ensures the boundaries between 
vector artwork and rasterized artwork fall along object paths. By selecting this option, you can 
reduce stitching artifacts that result when part of an object is rasterized while another part of the 
object remains in vector form.

Color model is the dimensional coordinate system used to numerically describe colors. Some 
models include RGB, HSB, CMYK, and L*a*b*.

Color space is a variant of a color model and has a specific gamut (range) of colors. For example, 
within the RGB color model are a number of color spaces: Adobe RGB, sRGB, and Apple RGB. 
While each of these color spaces defines color using the same three axes (R, G, and B), their 
gamuts are different.

Color stitching is the visible color transition that appears between objects whose coloring would 
otherwise be identical. It most commonly occurs when the Flattener rasterizes only a portion of 
a vector object.

Complexity region is an area that is rasterized because of a complex transparency interaction. 
Complexity regions are typically made up of a large number of objects that interact with trans-
parency. Flattening them would be time- or memory-intensive. Flattening a complexity region 
involves rasterizing all vector objects, images, and text inside the region using the Line Art and 
Text Resolution. Note that the Raster/Vector setting affects complexity regions. For example, it’s 
possible that you could have a rasterized complexity region when the Raster/Vector balance is set 
to 20, but not when the Raster/Vector setting is set to 80.

Convert All Strokes to Outlines is a Transparency Flattener option that converts all strokes to 
simple filled paths. This option ensures that the width of strokes stays consistent during flatten-
ing. Note that by choosing this option, you may cause thin strokes to appear slightly thicker than 
they otherwise would.

Convert All Text to Outlines is a Transparency Flattener option that converts all type objects 
to outlines and discards all type glyph information. This option ensures that the width of text 
stays consistent during flattening. Note that by enabling this option, you may cause small text to 
appear slightly thicker than it otherwise would.
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CT/LW (Continuous Tone/Line Work) are the two file formats used by Creo (Scitex) Brisque and 
PS/M RIPs. Other dual resolution RIPs use similar file types.

D
Document color mode is an Illustrator CS2 setting that specifies the color space for a document. 
Illustrator CS2 does not support using elements in multiple color spaces (CMYK and RGB) in a 
document. In Illustrator CS2, the Transparency Flattener works in this color space. 

Document Raster Effects settings are the settings Illustrator uses whenever you apply a raster-
based effect to an object. The raster effects settings can have a large impact on the resulting art-
work; therefore, it’s important to check the Document Raster Effects Settings dialog box before 
you export or output a document that contains raster effects.

Drop shadow is a live creative effect that you can apply to objects or type in Illustrator, 
InDesign, or Photoshop. Applying a drop shadow to an object makes it a source of transparency 
and requires the Transparency Flattener to process it.

Dual resolution RIP is a RIP in which each page is created in an intermediate, unscreened 
rasterized format consisting of two files—a relatively high-resolution file (the Line Work) that 
contains geometric shapes and text and a lower-resolution file (the Continuous Tone) that con-
tains the images.

F
Fatten is the process of replacing low-resolution or omitted image data with high resolution im-
age data. See OPI and APR.

Feather is a live creative effect that you can apply to objects in Illustrator or InDesign. Applying 
a feather to an object makes it a source of transparency and requires the Transparency Flattener 
to process it.

Flattener Presets are similar to paragraph styles for text; however, instead of containing text 
formatting, a Flattener Preset contains the settings the Flattener will use when flattening trans-
parency. Custom Flattener Presets can be created and saved for reuse. In addition, a Flattener 
Preset created by InDesign can be used by Illustrator and vice versa. Both applications include 
three built-in presets that cannot be modified or deleted: Low Resolution, Medium Resolution, 
and High Resolution.

Flattener Preview palette is a palette window in Illustrator, InDesign, and Acrobat 7 Profession-
al that you can use to highlight objects that are a source of transparency or that will be affected 
by the flattening process.

Flattener is also known as Transparency Flattener. See Transparency Flattener.

G
Glyph is a specific form of a character. Certain characters may be represented by a number of 
glyphs. For example, in certain fonts, the capital letter A is available in several forms, such as 
swash and small caps.

Gradient and Mesh Resolution is the Flattener setting that determines the resolution applied to 
any gradient meshes and gradients that are involved in transparency. In addition, InDesign CS2 
applies this resolution to all InDesign drop shadows and feathered edges.

Gradient mesh is a single, multicolored Illustrator object on which colors can flow in different 
directions, and smoothly transition from one point to another, to simulate watercolor style effects.

Gradient is an Illustrator or InDesign object fill or stroke containing a graduated blend of colors. 

I
Ink Manager is the InDesign component that lets the user control the output of each color in a 
document. You can use the Ink Manager to convert spot colors to process or to cause one spot 
color to be output with another color. Converting spot colors of placed graphics to process can 
cause unintended results if the Transparency Flattener processes those elements.
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Interacts with transparency is a term applied to objects which themselves may not be transpar-
ent but will be affected by the Flattener during the flattening process.

L
Line Art and Text Resolution is a Flattener setting that determines the resolution applied to ar-
eas that need to be rasterized because they are too complex for the current Raster/Vector Balance 
setting. The Line Art and Text setting is intended primarily for vector objects, but in some cases, 
you can apply it to type or images. Typically, this resolution should be set to match the resolution 
of your output device.

Live effects are Illustrator operations found on the Effects menu that have specified properties, 
but they remain editable. You can apply an effect command to an object and then continue to 
modify the effect’s options or remove the effect at any time by using the Appearance palette. 
The application of certain Illustrator effects, like drop shadow, feather, and glows, will make an 
object a source of transparency.

Live transparency refers to any transparent attributes that are specified but not yet executed 
(flattened). Keeping transparent attributes live lets their properties be changed at any time before 
output, or in the case of Illustrator, explicit flattening.

O
Object flattening is an Illustrator option that lets you flatten individual objects while you edit 
the file. Select the objects you want to flatten and choose Object > Flatten Transparency. Object 
flattening is not available in InDesign or Acrobat.

Opaque is the color attribute of an object that totally obscures any underlying objects. With the 
exception of overprint, the PostScript imaging model creates opaque objects.

Open Prepress Interface (OPI) is an industry-standard mechanism for you to use low-reso-
lution proxy images in a page layout application that are replaced with their high-resolution 
counterparts by a RIP or by an OPI server. You must be careful not to use OPI proxy images if 
they interact with transparency, or the proxy image will be processed into the final output by 
the Transparency Flattener, preventing high-resolution substitution at the RIP. See Automatic 
Picture Replacement (APR).

Overprint is a color attribute that specifies that the colors (inks) of an object to which it is ap-
plied should not erase (knockout) other inks in underlying objects. Because the Transparency 
Flatteners in Adobe products may rely on overprint for proper rendering of the flattened output, 
it is important that viewing applications, as well as proofing and final output devices, implement 
and honor this attribute.

Overprint Preview is a display option in Illustrator, InDesign, and Acrobat 7 Professional that 
shows the effects of any object overprint attributes. Because the Transparency Flatteners in 
Adobe products may rely on overprint for proper rendering of the flattened output, it is impor-
tant that you view flattened output in an application that provides this capability and that you 
enable it.

P
Pages palette is the InDesign palette that shows the document’s pages and spreads. One feature 
of the Pages palette is that each page that contains any transparency is displayed with a distinc-
tive checkerboard background, which gives you a quick visual confirmation of the pages that the 
Transparency Flattener will process.

Preserve Alpha Transparency is an Illustrator Object Transparency Flattener option that only 
takes into account the attribute of opacity. It does not include blending modes. After a user flat-
tens artwork with this option chosen, alpha transparency remains, and the resulting artwork 
is suited for SVG and SWF web formats. All objects with blend modes other than Normal are 
flattened and the appearance of artwork is preserved. In general, you should not use this setting 
in the context of print workflows.

Preserve Overprints and Spot Colors is an Illustrator Object Transparency Flattener setting 
that is only applicable to explicit flattening by using Object > Flatten Transparency. This option 
produces the same effect as Preserve Overprints in the Advanced pane of the Print dialog box.



Adobe Systems Incorporated • 345 Park Avenue, San Jose, CA 
95110-2704 USA • www.adobe.com

Adobe, the Adobe logo, Acrobat, Acrobat Distiller, Extreme, 
Illustrator, InDesign, Photoshop, PostScript, PostScript 3, Reader 
are either registered trademarks or trademarks of Adobe Systems 
Incorporated in the United States and/or other countries. 
Helvetica is a trademark of Heidelberger Druckmaschien AG 
exclusively licensed through Linotype Library GmbH, and may be 
registered in certain jurisdictions. SVG is a trademark of the World 
Wide Web Consortium; marks of the W3C are registered and held 
by its host institutions MIT, INRIA and Keio.

All other trademarks are the property of their respective owners.

© 2005 Adobe Systems Incorporated. All rights reserved.

Process color is one of the four subtractive primary colors used in four-color process 
printing—Cyan, Magenta, Yellow, and Black.

Proxy image is a low-resolution placeholder image that you can use in page layouts in 
conjunction with OPI or APR systems. Be sure not to let proxy images interact with 
transparency or the low-resolution data will be processed into the final output by the 
Transparency Flattener.

R
Raster/Vector Balance is a Transparency Flattener setting that specifies the desired 
degree of rasterization. The higher the setting, the less rasterization is performed on the 
artwork. Select the highest setting to keep as much artwork as possible as vector data; 
select the lowest setting to rasterize all of the artwork.

S
Seam stitching is the appearance of visible artifacts (white or black lines displayed in 
the flattened image) or differences along the borders of atomic or complexity regions.

Separation Preview palette is a palette in Illustrator, InDesign, and Acrobat 7 Profes-
sional that dynamically shows color separations individually or in any combination 
along with a dynamic densitometer that measures and displays separation values at the 
current cursor location on the page.

Simulate Overprint is an output option in various print and export dialog boxes in 
Illustrator, InDesign, and Acrobat 7 Professional. If you choose this option, the Trans-
parency Flattener will preprocess all overprint attributes and render them without reli-
ance on overprinting. This option can be useful for creating proofs that will be viewed 
or printed on devices that do not have support for overprinting, but it is generally not 
advisable for final production output. Note that choosing this option converts spot 
colors to process in any affected area.

Source of transparency is any object that has one or more of the following charac-
teristics: has an opacity less than 100%, has a non-Normal blending mode, has a drop 
shadow, or has a feather.

Spot color is a nonprocess color that you may use alone, with other spot colors, and 
with one or more process colors.

Stacking order is the front-to-back or top-to-bottom order of objects on a page, both 
within and between layers. Objects that are beneath transparent objects in stacking 
order may be unnecessarily and unfavorably affected during transparency flattening.

T
Transparency is an effect applied to an object that causes it to appear transparent. A 
transparent object lets objects that lie underneath it to show through.

Transparency Blend Space is an InDesign setting that controls if the Transparency 
Flattener uses CMYK or RGB color space in making its color calculations. To avoid 
unintended color shifts during flattening, it is important to properly set the Transpar-
ency Blend Space.

Transparency Flattener is the software component of Illustrator, InDesign, and 
Acrobat 7 Professional that processes objects with live transparency effects, along with 
objects with which they interact, and recreates their visual appearance by using opaque 
objects that can be rendered in the PostScript imaging model.

Transparency interaction is the relationship between a source of transparency and any 
other object that is a source of transparency, is overlapped by a source of transparency, 
or is very close to (usually within one point of) a source of transparency, and is beneath 
it in stacking order.
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