Share

PropertyEnum(T) Class

Property template for enumerations.

Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.4.208.0

Syntax

C#

public class PropertyEnum<T> : Property<int,int,Autodesk::Civil::CastOp<int,int> >
where T : struct, new()

Visual Basic

Public Class PropertyEnum(Of T As {Structure, New}) _
	Inherits Property<int,int,Autodesk::Civil::CastOp<int,int> >

Visual C++

generic<typename T>
where T : value class, gcnew()
public ref class PropertyEnum : public Property<int,int,Autodesk::Civil::CastOp<int,int> >

Type Parameters

T

Inheritance Hierarchy

System.Object
  System.MarshalByRefObject
    DisposableWrapper
      TreeOidWrapper
        Autodesk.Civil.Property<int,int,Autodesk::Civil::CastOp<int,int> >
          Autodesk.Civil.PropertyEnum<T>

See Also

Was this information helpful?