Enumerates where to anchor various label annotations.
Namespace: Autodesk.CivilAssembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.4.208.0
Syntax
C#
public enum AnchorLocationType
Visual Basic
Public Enumeration AnchorLocationType
Visual C++
public enum class AnchorLocationType
Members
Member name | Value | Description | |
---|---|---|---|
TopLeft | 134263044 | ||
TopCenter | 134263045 | ||
TopRight | 134263046 | ||
MiddleLeft | 134263047 | ||
MiddleCenter | 134263048 | ||
MiddleRight | 134263049 | ||
BottomLeft | 134263050 | ||
BottomCenter | 134263051 | ||
BottomRight | 134263052 | ||
Start | 134263041 | ||
Middle | 134263042 | ||
End | 134263043 | ||
InsertionPoint | 134263053 | ||
Station | 134263072 | ||
LabelLocation | 134263073 | ||
PI | 134263074 | ||
PVI | 134263088 | ||
CurveStart | 134263089 | ||
CurveEnd | 134263090 | ||
PVIExtension | 134263091 | ||
CurveStartExtension | 134263092 | ||
CurveMiddleExtension | 134263093 | ||
CurveEndExtension | 134263094 | ||
CurveHighPoint | 134263095 | ||
CurveLowPoint | 134263096 | ||
TangentStart | 134263097 | ||
TangentMiddle | 134263098 | ||
TangentEnd | 134263099 | ||
TangentStartExtension | 134263100 | ||
TangentMiddleExtension | 134263101 | ||
TangentEndExtension | 134263102 | ||
StationExtension | 134263103 | ||
BandTop | 134263104 | ||
BandMiddle | 134263105 | ||
BandBottom | 134263106 | ||
StartExtension | 134263107 | ||
MiddleExtension | 134263108 | ||
EndExtension | 134263109 | ||
Offset | 134263152 | ||
GradeBreak | 134263154 | ||
GradeBreakExtension | 134263155 |
Remarks
Used in BlockLabelStyles, VectorArrowLabelStyles, LineLabelStyles, and TextLabelStyles.
There are nine anchor point values representing points along a rectangle that encompasses the entire text component and are relative to the rotation angle of the text.