Enumerates where to anchor various label annotations.
Namespace: Autodesk.CivilAssembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.4.208.0
Syntax
C#
public enum AnchorPointType
Visual Basic
Public Enumeration AnchorPointType
Visual C++
public enum class AnchorPointType
Members
Member name | Value | Description | |
---|---|---|---|
Start | 134263041 | ||
Middle | 134263042 | ||
End | 134263043 | ||
TopLeft | 134263044 | ||
TopCenter | 134263045 | ||
TopRight | 134263046 | ||
MiddleLeft | 134263047 | ||
MiddleCenter | 134263048 | ||
MiddleRight | 134263049 | ||
BottomLeft | 134263050 | ||
BottomCenter | 134263051 | ||
BottomRight | 134263052 | ||
InsertionPoint | 134263053 | ||
Center | 134263054 | ||
PointOfIntersection | 134263055 | ||
Station | 134263072 | ||
PI | 134263074 | ||
PVI | 134263088 | ||
CurveStart | 134263089 | ||
CurveEnd | 134263090 | ||
PVIDimension | 134263091 | ||
CurveStartDimension | 134263092 | ||
CurveMidDimension | 134263093 | ||
CurveEndDimension | 134263094 | ||
CurveHighPoint | 134263095 | ||
CurveLowPoint | 134263096 | ||
TangentStart | 134263097 | ||
TangentMiddle | 134263098 | ||
TangentEnd | 134263099 | ||
TangentStartDimension | 134263100 | ||
TangentMiddleDimension | 134263101 | ||
TangentEndDimension | 134263102 | ||
TangentInStart | 134263075 | ||
TangentInMiddle | 134263076 | ||
TangentOutMiddle | 134263078 | ||
TangentOutEnd | 134263079 | ||
StationExtension | 134263103 | ||
PVIStart | 134263120 | ||
PVIEnd | 134263121 | ||
PVIStartDimension | 134263122 | ||
PVIEndDimension | 134263123 | ||
CurveMid | 134263128 | ||
CurveHighPointDimension | 134263129 | ||
CurveLowPointDimension | 134263130 | ||
CurveStartInView | 134263184 | ||
CurveEndInView | 134263185 | ||
CurveStartInViewDimension | 134263186 | ||
CurveEndInViewDimension | 134263187 | ||
TangentStartInView | 134263188 | ||
TangentEndInView | 134263189 | ||
TangentStartInViewDimension | 134263190 | ||
TangentEndInViewDimension | 134263191 | ||
PVIStartInView | 134263192 | ||
PVIEndInView | 134263193 | ||
PVIStartInViewDimension | 134263194 | ||
PVIEndInViewDimension | 134263195 | ||
StartExtension | 134263107 | ||
MiddleExtension | 134263108 | ||
EndExtension | 134263109 | ||
Offset | 134263152 | ||
OffsetExtension | 134263153 | ||
GradeBreak | 134263154 | ||
GradeBreakExtension | 134263155 | ||
Centerline | 134263156 | ||
TopOuterDiameter | 134263157 | ||
TopInnerDiameter | 134263158 | ||
BottomOuterDiameter | 134263159 | ||
BottomInnerDiameter | 134263160 | ||
PipeDimension | 134263161 | ||
StructureDimension | 134263162 | ||
SectionViewTop | 134263168 | ||
SectionViewBottom | 134263169 | ||
SectionViewTopAtStart | 134263170 | ||
SectionViewBottomAtStart | 134263171 | ||
SectionViewTopAtMiddle | 134263172 | ||
SectionViewBottomAtMiddle | 134263173 | ||
SectionViewTopAtEnd | 134263174 | ||
SectionViewBottomAtEnd | 134263175 | ||
SegmentMiddleSuperelevationBand | 134264080 | ||
Insertion | 134264184 | ||
Dimension | 134264185 | ||
LabelLocation | 134263296 | ||
BandTop | 134263104 | ||
BandMiddle | 134263105 | ||
BandBottom | 134263106 | ||
PreviousStationBandTop | 134264160 | ||
PreviousStationBandMiddle | 134264161 | ||
PreviousStationBandBottom | 134264162 | ||
LengthMidBandTop | 134264163 | ||
LengthMidBandMiddle | 134264164 | ||
LengthMidBandBottom | 134264165 | ||
NextStationBandTop | 134264166 | ||
NextStationBandMiddle | 134264167 | ||
NextStationBandBottom | 134264168 | ||
SegmentStartAndBandTop | 134264082 | ||
SegmentStartAndBandMiddle | 134264083 | ||
SegmentStartAndBandBot | 134264084 | ||
SegmentMiddleAndBandTop | 134264085 | ||
SegmentMiddleAndBandMiddle | 134264086 | ||
SegmentMiddleAndBandBot | 134264087 | ||
SegmentEndAndBandTop | 134264088 | ||
SegmentEndAndBandMiddle | 134264089 | ||
SegmentEndAndBandBot | 134264090 | ||
SchematicLineStart | 134264091 | ||
SchematicLineMid | 134264092 | ||
SchematicLineEnd | 134264093 | ||
PreviousOffsetBandTop | 134264144 | ||
PreviousOffsetBandMiddle | 134264145 | ||
PreviousOffsetBandBottom | 134264146 | ||
NextOffsetBandTop | 134264150 | ||
NextOffsetBandMiddle | 134264151 | ||
NextOffsetBandBottom | 134264152 |
Remarks
Use for all the label style components.